Are these iMac trace route stats normal?

Mac Technical Support
All internet use at home is super fast, D3 is fine as well. System specs following traceroute stats.

1 ( 0.680 ms 0.746 ms 0.541 ms
2 ( 33.629 ms 34.699 ms 50.491 ms
3 ( 32.082 ms ( 231.314 ms ( 29.684 ms
4 ( 88.446 ms ( 85.458 ms ( 86.188 ms
5 ( 86.309 ms ( 88.890 ms ( 85.648 ms
6 ( 228.154 ms ( 81.771 ms ( 83.261 ms
7 ( 79.065 ms ( 231.414 ms ( 233.532 ms
8 ( 233.490 ms 227.754 ms ( 240.871 ms
9 ( 242.782 ms ( 243.055 ms ( 243.541 ms
10 ( 256.433 ms ( 252.197 ms 248.096 ms
11 ( 249.683 ms ( 247.014 ms ( 239.897 ms
12 ( 234.747 ms 236.434 ms ( 241.574 ms
13 ( 251.431 ms ( 256.761 ms ( 246.715 ms
14 * ( 244.512 ms ( 249.117 ms
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 *

I'm suffering constant lag with minimum latency of 250ms and frequent (very frequent, every 2-3 mins or so) spikes up to 20k! I have run the repair tool, deleted cache, wtf, interface, uninstalled, reinstalled etc... line speed tests always have me at home averaging 8mbps (anywhere from 6-9 but most often when I'm trouble shooting its about 8). This issue has existed since about 1 month POST MoP launch. It was fantastically lag free for the 1st month. I've even installed McAfee anti-virus last night with a full scan finding absolutely nothing. Seriously getting sick of it and its basically unplayable full tim now. Desperately need help.


Processor 3.4 GHz Intel Core i7
Memory 16 GB 1333 MHz DDR3
Graphics AMD Radeon HD 6970M 2048 MB
Software OS X 10.8.2 (12C60)
2 ( 33.629 ms 34.699 ms 50.491 ms

Hop 2 shouldn't be this high, as it should be similar to hop 1. Other than that, I think coming from the AUS/NZ region this looks like a normal typical trace. Would it be possible to run a trace when the spike happens? We might be able to locate the cause of it then.

Also, have you tried creating a new admin user account and playing on there to see if there is any improvements? Are there any other computers in the house having similar issues?
Took another trace during moderate lag... Murphy's law prevented anything decent happening ><

Will try making another user account tomorrow (don't have any other computers) and see if it makes a difference. Thank you very much for assisting with this, its been a very lengthy and painful process.

Actually on that note, no idea if it plays a part (I suspect not due to a few things a tried) but... I have 1 modem with 3 ethernet cables attached. One for Mac, one for tv and one for PS3 plus WiFi for iPad. Disconnected (physically) the other 2 ethernet cables and turned off WiFi in modem settings to see if it made a diff... didn't seem to change a thing. But just in case you think its playing a part in some way, thought I should tell you.

1 ( 0.837 ms 0.476 ms 0.394 ms
2 ( 44.212 ms 33.718 ms 42.269 ms
3 ( 36.879 ms ( 46.396 ms ( 46.941 ms
4 ( 105.998 ms ( 112.885 ms ( 106.583 ms
5 ( 82.297 ms ( 97.868 ms ( 99.428 ms
6 ( 120.633 ms ( 231.864 ms ( 100.578 ms
7 ( 244.380 ms ( 228.705 ms ( 232.915 ms
8 ( 235.915 ms ( 247.630 ms ( 227.487 ms
9 ( 237.673 ms ( 248.010 ms ( 244.366 ms
10 ( 242.679 ms ( 246.028 ms ( 241.444 ms
11 ( 236.734 ms ( 241.471 ms ( 249.671 ms
12 ( 235.481 ms ( 237.927 ms ( 236.072 ms
13 ( 239.937 ms ( 237.504 ms ( 238.399 ms
14 ( 244.909 ms * ( 237.960 ms
15 * * *
16 * * *
17 * * ( 238.201 ms
18 * * *
19 * * *
64 * * *
02/07/2013 02:41 PMPosted by Machkhan
Also, have you tried creating a new admin user account and playing on there to see if there is any improvements?

OK, I've just created another Admin account as you suggested but WoW wont launch properly. I tried 4 times and each time my account password was required because "World of Warcraft wants to make changes". I know thats probably just some default setting I changed when I 1st got the Mac, but can't remember where the setting is to change it (if that's the case).

Anyway, 1st time around I entered the password (as above). The above message pops up BEFORE the launcher 'launches' btw. The current message on launcher "Downloading data for an upcoming patch." was displayed, other than that, nothing out of the norm. Pressed PLAY... nothing happened. Had to Force Quit.

2nd time, all as above except this time it downloaded ~25MB from patch 5.1.0a (already installed). So once the DL was finished I pressed PLAY and again ended up Force Quiting.

3rd time all as above except instead of DL'ing the patch data, it simply showed the DL at 100%... PLAY > Force Quit.

4th time same as 3rd.

Logged out of the Admin account and back to my normal login and WoW launches as per normal. SO I will keep a trace route open and ready to go for the net big lag spike I get and see if I cant catch a bigger one for you. With the 2nd hop you mentioned as being off (seems considerably off), is that an ISP issue or still within my home 'network' situation?
Took this trace during lat (Home) 1305, (World) 1250.

1 ( 0.816 ms 0.415 ms 0.384 ms
2 ( 49.021 ms 52.317 ms 64.435 ms
3 ( 67.803 ms ( 44.213 ms ( 67.013 ms
4 ( 103.226 ms ( 86.167 ms ( 88.559 ms
5 ( 107.843 ms ( 121.139 ms ( 113.181 ms
6 ( 104.125 ms ( 92.805 ms ( 102.628 ms
7 ( 269.286 ms ( 243.422 ms ( 238.558 ms
8 ( 231.158 ms ( 93.958 ms ( 232.182 ms
9 ( 261.194 ms ( 252.460 ms ( 254.494 ms
10 ( 259.750 ms 263.830 ms 248.072 ms
11 ( 261.564 ms ( 249.961 ms ( 250.324 ms
12 ( 262.269 ms ( 269.633 ms ( 255.001 ms
13 ( 295.264 ms 266.336 ms ( 289.014 ms
14 ( 265.603 ms * ( 319.768 ms
15 * * *
16 * * *
64 * * *
2 ( 49.021 ms 52.317 ms 64.435 ms

Hop 2 is still high it seems. This is the trace where it leaves your network and goes to the first node of your ISP. They might be able to take a look at this and see if they can help in anyway in getting this lower.

As for the other admin account, something seems off. Can I get you to log back on that account and reset the game folder permissions? This will ensure all items in that folder have read & write for all users (including your original account). Then run the launcher and make sure everything is 100% and repair your game, to ensure all data is intact.
As for the other admin account, something seems off. Can I get you to log back on that account and reset the game folder permissions? This will ensure all items in that folder have read & write for all users (including your original account). Then run the launcher and make sure everything is 100% and repair your game, to ensure all data is intact.

OK, that got it working on alternative User Account. Still same latency issues though. What info should I provide to my ISP? Do I just need to tell them I'm having lag and my trace route is off from the 2nd hop? Not sure what I'll need to tell them. My main concern is they'll just do some line test and say everything is ok. How can I get their attention so they will actually look into it? Ie, level 2or 3 support etc...?

Again, thanks heaps for your help :)
No worries. It may be best to speak with a level 2+ tech, as they have more knowledge about what is going on.

You may want to tell them what your experience is like, and that you've contacted Blizzard technical support and they say a higher than normal ping after the connection leaves your house.
Since it's hop #2, that likely means he's hitting a snag on the ISP's DNS servers. There are a couple solutions. One is to flush the DNS cache and see if that helps any. To perform this task, type the following line in Terminal, and hit Enter:

dscacheutil -flushcache

Additionally, you can also type this line:

sudo killall -9 mDNSResponder

Enter your administrator password and hit Enter. Once done, quit Terminal and log out, and then back in.

The other option is to change your DNS server to use Google's public DNS server.

To do this, follow the link below and use the instructions for Mac OS X:

Using Google Public DNS:

Give these a go and see if they improve your latency any. Do note that there are frequent issues with Telstra Global, which is where your latency jumps significantly, but this is par for the course with them and there isn't much you can do (or that they're willing to do) to fix it. The best you can do is make sure your end is up to snuff.

Let us know how it goes! :)

Credit for the Google DNS information goes to Narull and Bluspacecow, our two ANZ MVPs.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.

thanks for your help guys. Have contacted my ISP (prior to seeing your feedback Tia) and went from bad to worse. We never 'really' got around to trouble shooting the latency. Long story short after 4 hours (literally) on the phone, my modem is fried (again literally) and they're sending me out a new one. It died during a firmware upgrade. Not sure if the modem was in anyway a part, or sole cause , of the problem as it wouldn't behave appropriately from the beginning of my ISP's troubleshooting (initially they just wanted to confirm my settings were correct before looking into the rest, but it all fell apart from the start... a very ouch worthy lol). I'd been having to reset it almost daily as the internet had been dropping out for around 2 months prior. Something I didn't think about when I first started speaking to you Machkhan.

Anyway, on the up front, the tech I was speaking to was a WoW geek and was very helpful in as many areas as he could be (at least he sounded helpful, hard to say when he fried my modem! lol).

All in all I'm now back on my old modem awaiting a new one and he's done a port rebuild on their end, and he's referred me to and proxycap to help lower the latency. Can't get that program working on my Mac, so ditching it all.

Have just followed your suggestions Tia and am about to test WoW out now. Haven't yet changed to Google public DNS, but if this doesn't work, that's my next step. Thanks very much again for your continued assistance.
OK just a quick note to let you know I've got my new working modem, but the problem was fixed prior to that. I went back to my old modem and just followed the following from Tiapriestess:

02/11/2013 09:01 PMPosted by Tiapriestess
dscacheutil -flushcache


02/11/2013 09:01 PMPosted by Tiapriestess
sudo killall -9 mDNSResponder

with great effect. Am now back raiding 25 mans with no lag whatsoever. Thank you both so very much :)

Join the Conversation

Return to Forum