Cataclysm gaming mouse not working

Technical Support
I already searched for previous threads on the issue and the majority of them are answered inadequately. I quit and recently came back and since then got another mouse but now that I'm playing again I need all the buttons for binds. As of right now, all of buttons are bound to strange things like my map.

Whenever I use "in-game mode" on the driver's interface, only two of the buttons work at that point for anything, they're freely bound to anything. However, none of the other buttons do anything at all. I know I can map them to be bound to buttons on my keyboard, but I didn't used to have to do that and I want to know how to get them all to work like the two that currently do (When I bind them, they're marked as "Mouse button X", which is what I want but it currently only works for the two upper thumb buttons, mouse buttons 4 & 5).
Whenever you check the "in-game mode" box all of the buttons grey out, you have to log in and use World of Warcraft's' key binding interface. If you don't want to do that, uncheck the "in-game mode" box and map your keys with the mouse software.
Always make sure to hit the "Apply" button first and test it out, then hit "OK"
I have the wow mouse as well. With that turned on in the software, you also have to enable the mouse in game for all the buttons to work. Go to your interface options, Go to Mouse, and click Detect WOW gaming mouse. That will enable the other buttons..

I had this same issue with that clicked, it fixed it right up.
i have the mouse now and my computer wont even find the mouse, when it does want to work when i try to key bind the buttons it binds to weird things like button six when i try to bind to action button 1 it does crt+t or some weird thing, any advise
I have the same kind of issue. Only about half of the buttons on the WoW Cata mouse will bind since a few patches ago. The mouse itself is not faulty as the same issue happens with my spare. I tried reinstalling the drivers several times but it made no difference.
I have always bound them using the in game Keybinding interface.
This happened to me as of yesterday. Actually I'm concerned about it because I cannot play the game as is - I depended on my shift key being a mouse button. Though I believe in my case it may have been due to static electricity. I continuously would hit it with static on accident and it would bring up a small window saying "Do you want to overwrite on-board profile with current settings?" or something similar - and the mosue wouldnt work until this window popped up. Though while playing the game I BELIEVE this occured and I accidentally hit yes, which I assume is what messed everything up for me.
Actually I forgot to mention that some buttons hold their OLD keybinds after being reset to new ones, and some keys do not seem to function.
How can I bind all of the buttons on my WoW: Cataclysm MMO mouse?

There are two options to bind the buttons on your World of Warcraft Cataclysm Mouse. First, you can use our software to create advanced macros and keybinds. Second, you can use the exclusive World of Warcraft in-game integration which recognizes all 14 buttons individually. See below for instructions on utilizing the in-game integration.
1. If you are using the World of Warcraft MMO Gaming Mouse software, select desired illumination and
performance settings. Check the “Enable In-Game Mode” option.
2. Launch World of Warcraft
3. Open “Game Menu”
4. Click “Interface” and select “Mouse” section
5. Check the “Detect World of Warcraft Gaming Mouse” option and press “Ok”
6. Click “Key Bindings”
7. Scroll down to your desired function that you wish to bind to the World of Warcraft MMO Gaming Mouse and then press the desired mouse button. Repeat this step for all functions you wish to be associated with mouse buttons.
8. Press “Ok” and click “Return to Game”
9. That’s it! Enjoy using the World of Warcraft MMO Gaming Mouse!


Your questions regarding this mouse is best placed over in the Steelseries forums as they are the manufacturer of the mouse itself. If you think the mouse is not doing something correctly they may be able to assist you.
Just download the drives for the mouse don't download engine one or two from the steelseries it wont help and if you did remove it from your files. My mmo legendary mouse connected to the wow account on its own the first time I downloaded the drives, but once I reinstalled windows 10 only two buttons worked, I had to download the drives then lunched the wow game. Hit escape button, interface, click on mouse and hit detect mmo mouse all your buttons will work on the mmo mouse.
Good luck this worked for me.
The new steelseries engine does not working for this product which is sad.

Use this website please click Mirror 1 I just redid this for a buddies pc.
http://www.techspot.com/drivers/driver/file/information/15560/
i made a Macro and it works awesome to get the game to see your old cata MMO gaming mouse

/console enableWowMouse 1
now they have removed it from the game!!!!
thanks, that macro helped

Join the Conversation

Return to Forum