Character Stuck on Mac, not on Windows

Mac Technical Support
I have a problem that has just completely baffled me and was hoping someone here would know how to fix it.

In short, when I play on my mac, I can't log into my main. However i can login into her when I play on my windows machine and I can log into other characters on the same account with the mac version of wow.

The background: I was running Naxx on my main with a couple of friends when my computer crashed. When I restarted my computer and got everything loaded, I found that I couldn't log into my main, the loading screen would freeze about a fifth of the way into loading. After three or four unsuccessful attempts, I tried logging into a different character on that same account and was able to complete the naxx run.

Since then, the only time I can log into my main is if I am using my windows machine. I just have no idea of how to fix this problem and it is hurting my character as my windows machine has a problem with overheating and I use the mac to give the windows machine time to cool down.

I've tried deleting the cache and the problem still remained, and thought about deleting the wtf folder but as it's only one character that appears to be affected, I am not sure that would fix the problem.

Anyone else experienced this problem and know of a way to fix it?
There are character specific cache files in the WTF folder. It's possible that's causing the issue.

Try deleting all cache files/folders


Applications -> Utilities -> World of Warcraft -> Cache
Applications -> Utilities -> World of Warcraft -> Data -> Cache

Applications -> Utilities -> World of Warcraft -> WTF -> Account -> Your account name -> Realm -> Character -> cache.md5

Users -> Shared -> Blizzard

Then after all the cache folders are deleted then start up from the Launcher , wait a few minutes then click Play.
Thank you Blue. It worked and I can access my main from the mac again.
Love it when a gut feeling turns out to be correct :)

Join the Conversation

Return to Forum