Stuck on "Updating Blizzard Launcher".

Mac Technical Support
The bar fills up about 2/3 of the way, and then stops. I checked for the "agent" process in activity monitor, but I don't see one. Never had this problem before - just started happening on Wednesday.

MacBook Pro 5,3
OS X 10.6.8 (Snow Leopard)

Just wondering if there's anything to try before I attempt an upgrade to Mountain Lion (not sure if this would solve the problem or not).


Update: Figured it out - deleted the folder in Users>Shared and now I'm good. Woo!
I've had the exact same issues, also starting around Wednesday. I tried a complete reinstall, and it's still happening. Then I saw this thread and found that deleting the folder worked, however it's only a temporary fix. It looks like I have to do this every time I play.

iMac mid 2007
Mac OS X Lion 10.7.5

Thanks in advance!

EDIT: I've found that if I force close while it's updating and re-open that it'll launch, though I have to do this every time.

Join the Conversation

Return to Forum