WoW client or website wont load. Please help.

Mac Technical Support
Today I got home went to play wow and the game client just keeps saying initializing. So I went to go check the forums and worldofwarcraft.com and battle.net wont load up. Every other website loads up besides those. Since the client downloaded something a few days ago ive just keep getting problems. Thanks for your help.
Same here, stuck on Initializing..
Same here, yesterday the game or the website did not want to load. Today, I have deleted the Cache folder and WoW started to patch the files again. I was able to play until it started to lag really bad. The computer was red down on the bar and it stood that way until I exited the game. When I tried to load it up again, it is currently stuck on "Updating Blizzard Launcher". I have tried deleting the cache folder again and no luck. Any help is appreciated.
Did you try moving the Battle.net folder from /Users/Shared to the desktop and launching again to see if it helps?

Also, you may want to try flushing your DNS to see if it helps.

Join the Conversation

Return to Forum