Mobile Auction Autofilling Wrong

Mobile Bug Report
I was selling striped melons, I had listed two stacks melons previously a stack of 8 and of 12, I had 8 melons in my bag, the prices for the stacks were listed correctly at that time. I took the 12 out of the auction to combine it with the 8 in my bag and left the other stack of 8 in the auction. I logged into the game and combined the 8 from my bag and 12 I took out of the auction to make a stack of 20 that I left in my bags, then logged back out. Once the mobile auction house became available again I went in to list the stack of 20. The other 8 stack was still in the auction and was the lowest per item price at the time.

How the mobile app has worked for me previously is it will auto fill a buyout price based on your settings unless there are no like items with a buyout price list or you have not listed a like item previously with a buyout price. In this case I had it set to per item and set it to “remember the last price set per item”, so if the app was working correctly the price it set for the stack of 20 should have been my last item price times 20 since I had a stack of 8 listed and it was the lowest buyout price. I don't recall whether I checked at that time or not to see if it set it correctly, but when they sold I only got the single item price for the entire stack 20 and the proper stack price for the stack of 8 that the price for the stack of 20 was based on. It appears that the app failed to multiply the item price buy the number of items in the stack of 20. The only way I could have done this myself if the app was working correctly would be after it had set the buyout price base on the last per item price, would be to ignore that fact that is was filled in correctly as I wanted it and then switched the setting to per stack price, then the app would if working correctly have multiplied the per item price times 20, I would then have to have manually change a blatantly obvious correct buyout price for a stack to the exact per item of the stack of 8 last listed despite having just changed it to per stack pricing. Just to be clear I had my wits about me and no I don't even so much as drink alcohol so I was not impaired at the time.

I have been to told by a GM the it was human error they didn't seem to understand how the auction app autofills prices, I say my only error was to assume the app would work correctly. At the time of this posting the monies for these two stack from the auction are still in my mail, so customer support can see them for themselves see what I got for each stack after letting the app autofill the price for me.
I'm sorry to hear about that, Rockerx. I can't assume to know what you know you did at the time, but I believe this was due to a variant of the following user workflow:

Navigate to the Sell page in the Auction House, select any item, change either the "Starting Price" or "Buyout Price", and then toggle from "Price / Item" to "Price / Stack" (or vice versa). This will fail to update the prices dynamically.

I've brought up this specific workflow in the past, but as it turns out, this is an edge case side effect for a more critical workflow issue. I don't remember this more ill conceived defect off the top of my head, so I'll revisit this with the team to see what we can do.
Hola!

I noticed something which could be connected to Rockerx's problem.

It's quite easy to recreate the problem.

First, we ensure that the following are set :
1) Under [Settings -> Auction House], we set it to "Remember last price set for item."
2) Check the Price/Item radio button. I am assuming that it is working as intended, i.e. it remembers this setting the next time you sell too.

Now, head to the sell page and list a stack of something to sell. For the stack size, choose anything other than 20. (20 seems to be the cause of the bug.)

Let's just say we choose to list 1 stack of 5 Bolts of Embersilk Cloth at 15g Starting / 20g Buyout per item. Confirm and list it.

That will bring us back to the Sell page.

Choose Bolt of Embersilk Cloth again.

It will now remember your last stack size, Price/Item setting and auto-fill the last price you sold it at, which is 15g/20g.

Increase the stack size to 10 now. List 1 stack of 10 with the auto-filled settings. Confirm the listing.

That will bring us back to the Sell page again.

Now repeat the same steps again, except now list and sell a stack of 20 Bolts of Embersilk Cloth. It will use the auto-filled settings correctly.

Now here's where the bug is.

Back at the sell page, select Bolt of Embersilk Cloth.
You will notice that the settings all remain the same, i.e. still at 1 stack of 20, still Price/Item.

However, look at the auto-filled price settings.

For mine (iOS app on iPhone5), it has gone and changed the price to 0g 75s 0c Starting / 1g 0s 0c Buyout.

So I ran one more iteration to make sure it's stacks of 20 that is causing it.

We change the prices back to 15g Starting and 20g Buyout and list the stack.
Now at the sell page, select Bolt of Embersilk Cloth yet again.

Lo and behold, it has gone and changed it to 0g 75s 0c Starting / 1g 0s 0s Buyout again!!!

So in Rockerx's case, he/she must have confirmed a sale without double-checking the listing prices because he/she didn't expect such a quirky bug where the app went ahead and took his original Price/Item prices and further divided them by 20 (for no good reason, i might add).

Please have the development team look into this? It is not a life and death situation but sure gets on your nerves after awhile if you list a lot of stuff in 20s. =P

Thanks for the great work so far!

[Edited to correct the price numbers.]
Thank you wilebosk and whosaidthat for replying to my post.

Note: I use an ipod touch 5th gen

I have been watching and waiting for it to happen again but did not with the striped melons it has work properly with others melons I have listed, However it just happed again this time with windwool cloth (I'm looking at it right now as I write this), but it has been a day or two since I last listed any cloth, I sold that for around 2 gold per item. Now today I went to list a stack of 20 windwool cloth after listing a small stack of 3 pieces of crab meat (both straight from my bag). Setting are "price/item" (I don't use "price/stack when selling) and "remember last price set for item". The "buyout price" it set is 10s 40c. multiply that by 20 and that's 2g 8s which appears to match what I remember I sold the last set for using "price/item". Also just to note I never sell less than a stack of 20 with windwool, currently in my bag I have 43 pieces of it.

This is long as it details a number of things I tried (while writing this, so this is not from recollection) to see if anything I could think of would clear up the glitch.

I switched to "price/stack" it shows 2g 8s for the stack of 20. If I choose "match current cheapest price" it does match it correctly. If I change the Setting back to "price/item" (I did not after this use the "price/stack" setting) and "remember last price set for item" and hit "reset all" to update the price it again dividde the last per item price by 20. I logged out and logged back in and tried listing it again, still it divided the last per item price buy 20.

Next I listed a stack of twenty from my bag using "price/item" and "match current cheapest price" and it matched it correctly which was 3g 15s and I select "confirm" to complete the listing, I check the auction listing for it and it was listed correctly, then I went out and select windwool cloth from my bag again using a stack size of 20, it was still set for "match current cheapest price" and it filled the correct matching price of 3g 15s, I then changed it to "remember last price set for item" it filled in the per item buyout price for the stack of 20 as 15s 75c which is 3g 15s divided by 20, so the glitch still persisted.

I then switched back to "match current cheapest price" however in the mean time someone else listed windwool cloth for 2g 75s, and that was what it filed in as the per item buyout price, I then confirmed the listing and checked the auction and it listed correctly. I next canceled my prior listing of 20 and directly relisted it from the cancelled list. It was still set for "match current cheapest price" and filled in the per item buyout price as as 2g 75s which is correct. I then changed the settings to "remember last price set for item" went back and hit "reset all" to update the price, it changed the per item buyout price to 13s 75c which is 2g 75s divided by 20.

In the mean time the last stack I listed sold but there were still others listed for 2g 75s, I then without out changing any settings manually set the starting price and per item buyout price to match the current cheapest price, I listed it and it showed correctly in the auction. I then selected my remaining 3 pieces of windwool just to test it (I did not list them in the auction), and again it filled in the per item buyout price as 13s 75c. I then logged out and turned off the ipod, turned it back on and logged back in and repeated the last with the same result. I did no further tests. If the next time I list windwool anything changes I will note in in this thread.

If you made it this far thanks for reading my tedious ramblings detailing my actions involving this instance of the glitch.

(edited for typos)
Thanks Wilebosk for your attention to this and your reply, it happened again this time with windwool cloth, I was watching for it so I caught it and was able to try many things to see what would happen. As you can see when I detailed them in another entry in this thread. Thanks again.
We plan to have this resolved in the next update to the Mobile Armory.

Join the Conversation

Return to Forum