Unstable FPS along with Lag

Mac Technical Support
I seem to have some very unstable FPS along with bad lag. This is usually while zoning into a city for the first time, or during the start of the raid encounter.

I did recently update my Energy Saver to NOT auto switch, and honestly haven't played enough to see how much that has improved my system. But even with this change I am still having FPS issues.

Here is my computer info:
Model Name: MacBook Pro
Model Identifier: MacBookPro9,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: MBP91.00D3.B08
SMC Version (system): 2.1f170
Hardware UUID: 6DDAA996-3960-5F62-AF3C-464D654F4295
Sudden Motion Sensor:
State: Enabled
Software OS X 10.8.2 (12C3012)
Graphics NVIDIA GeForce GT 650M 512 MB

I did run two trace reports. One was run during normal FPS and one while experiencing low FPS.

1 ( 3.544 ms 0.771 ms 0.622 ms
2 * * *
3 opti37-33.nassau.cv.net ( 8.956 ms 27.639 ms 7.934 ms
4 rtr4-ge1-4.mhe.hcvlny.cv.net ( 13.086 ms 10.841 ms 12.590 ms
5 451be0b9.cst.lightpath.net ( 16.236 ms 18.768 ms 11.206 ms
6 ( 13.533 ms
451be085.cst.lightpath.net ( 11.221 ms
rtr4-tg10-1.in.nycmnyzr.cv.net ( 11.050 ms
7 xe-1-1-0.gw13.nyc1.alter.net ( 21.586 ms 12.781 ms 13.064 ms
8 0.xe-7-0-1.xl3.nyc1.alter.net ( 13.884 ms 13.428 ms 16.618 ms
9 0.xe-4-2-0.br2.nyc4.alter.net ( 12.281 ms 38.227 ms 13.162 ms
10 ( 13.893 ms 10.983 ms 13.129 ms
11 cr2.n54ny.ip.att.net ( 14.383 ms 15.478 ms
cr1.n54ny.ip.att.net ( 31.179 ms
12 gar1.nw2nj.ip.att.net ( 11.289 ms
gar1.nw2nj.ip.att.net ( 84.901 ms 156.177 ms
13 ( 28.250 ms 13.225 ms ( 12.270 ms
14 mdf001c7613r0003-gig-12-1.nyc3.attens.net ( 12.859 ms
mdf001c7613r0004-gig-10-1.nyc3.attens.net ( 15.577 ms 12.500 ms

1 ( 0.836 ms 0.655 ms 0.562 ms
2 * * *
3 opti37-33.nassau.cv.net ( 8.272 ms 9.348 ms 10.907 ms
4 rtr3-ge1-4.mhe.hcvlny.cv.net ( 11.057 ms 10.407 ms
rtr4-ge1-4.mhe.hcvlny.cv.net ( 10.867 ms
5 451be0b5.cst.lightpath.net ( 12.728 ms
451be0b1.cst.lightpath.net ( 13.564 ms 10.465 ms
6 ( 13.510 ms
451be085.cst.lightpath.net ( 11.047 ms
rtr4-tg10-1.in.nycmnyzr.cv.net ( 12.724 ms
7 xe-1-1-0.gw13.nyc1.alter.net ( 12.713 ms 12.315 ms 13.062 ms
8 0.xe-7-0-1.xl3.nyc1.alter.net ( 13.458 ms 11.241 ms 12.952 ms
9 0.xe-4-2-0.br2.nyc4.alter.net ( 19.527 ms 12.302 ms 25.503 ms
10 ( 20.187 ms 42.959 ms 86.095 ms
11 cr1.n54ny.ip.att.net ( 17.562 ms 15.149 ms
cr2.n54ny.ip.att.net ( 14.573 ms
12 gar1.nw2nj.ip.att.net ( 14.687 ms
gar1.nw2nj.ip.att.net ( 12.564 ms 11.476 ms
13 ( 14.898 ms 11.822 ms ( 27.618 ms
14 mdf001c7613r0004-gig-10-1.nyc3.attens.net ( 35.972 ms
mdf001c7613r0003-gig-12-1.nyc3.attens.net ( 16.420 ms 11.871 ms

Thanks for your help!
Is this FPS issue recent or has it always been occurring?
Can you provide what actual values (X fps/Y ms) you are seeing when you experience low FPS and/or high latency?
My FPS drop as low as 4 and as high as 12 or so.

The FPS issue has always been an issue. The latency issue doesn't seem to be an issue lately.
Ok then, let us focus on the FPS issue.

Have you done all steps outlined in our World of Warcraft Low Performance article? A lot of those steps have been known to resolve low FPS issues.
Ok, I have in the past done all the steps. I did the repair and that has seems to really helped out a lot.

Now I do lag down to like 12FPS but only for a brief moment and last night during Sha I didn't lag during the start of the encounter like I have in the past. I think my issues are fix.

Thank you
Currently experiencing this same issue. Already ran the troubleshooting steps indicated in the linked article. But consistently getting 12-17 fps when standing in any area (I've tried multiple) and 8-12fps while in combat (tried in quests, 5 man, 10 man reg, 25 man lfr, and 10 man bg) while latency stays around 60-70ms.

I've turned down all settings in game to fair or low to even get that many frames.

Just randomly occurred Yesterday, after taking a break from doing vp grinding. Was working fine after the update Tuesday, but logged out yesterday and when I logged back in last night horrible fps.

Submitting a ticket, but thought I'd post it here too, since I tried the steps listed and in at least my case they did not help.

Computer stats:

MacBook Pro Retina, Mid 2012
Processor 2.6 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 650M 1024 MB
Software OS X 10.8.2 (12C3012)
APPLE SSD SM512E Media with 386.05 GB available
Well it seems that my problem is back. FPS were down as low as 1.5FPS when I port into a city.

Have you tried taking the WTF & Interface folders out of the wow folder and testing if it drops down then ?

Have you checked Activity Monitor to see if anything's taking up a lot of CPU time right at the FPS drop ?

Mac Tech Support MVP.
Not processing forum posts Fri 6 PM NZST to Sun 6 PM NZST
IRL Work comes first
I have tried and done both of those items.

I did look today at the activity monitor and wow was using over 60% while my toon was hanging out at the Shrine. The only other CPU use was Safari and it was low usage.
I should also note that sometimes when I first launch wow my entire screen flash to a garbled screen. Typically it is black and white zig zag blocks with a bunch of white little dots. I will try to grab a screen shot of it next time it does it.

Here is the screenshot of what it looks like when I launch WoW
60% CPU usage isn't bad, so it does not sound like that is causing an issue. I'll check with the team if the garbled screen is something that may be indicating issues.

When the game launches, are you in fullscreen, windowed, or windowed-fullscreen mode?
Windowed-Fullscreen mode
Thanks. How's it look with today's patch?

Also, make sure you reset your ui to see if it helps.
Today's (Yesterday's) Patch didn't seem to have much effect. I would say I had more lag, but of course being on the Island doesn't help.

I haven't "reset my ui" Once I do that I lose my settings for my addons, and macros - right?

I did recently try the "purge" command because I noticed my "inactive memory" at over 1g and my active memory in the MB range. For the brief time I played the AH this morning it did seem that helped. But I need to try this a bit more to see if it really does.
Addons, yes, but marcos, no. Those are server side.

To be safe, you can do this alternative version of the UI reset.

    1. Navigate to /Applications/World of Warcraft
    2. Move the WTF, Cache and Interface folders to the desktop
    3. Now go into the Data folder and delete the Cache folder
    4. Navigate to /Users/Shared and delete the Battle.net folder
    5. Launch the World of Warcraft Launcher. Let all updates apply and hit Play when Game is up to date is displayed.
I am having the same FPS issue. I have tried the UI reset listed above and did not install any addons. Still only getting 11-20 frames max where before I was getting 50-60. Can turn everything to low and still only max out at 30. Here is my system info:
Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32
Serial Number (system): C02JL17YDKQ4
Hardware UUID: 3E9CAB18-DFBD-5770-BE75-48CF025D129B
NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]

Join the Conversation

Return to Forum