Blizzard Launcher

Technical Support
Each time I open WoW, it makes me update my Blizzard launcher. Just wondering if anything can be done about it.


Try this:

1. Make sure that Windows is set to show hidden files.

Here's how to do that:

2. Navigate to the C:\ProgramData folder and delete the folder and the Blizzard Entertainment folder.
3. Navigate to the WoW folder and delete the "Updates" folder.
4. Launch WoW.

Let me know what happens.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
I seem to be having the same problem this evening. I was playing on WoW just fine today and I logged off as normal this afternoon. However, now when I goto launch WoW it just sits there on the 'Updating Blizzard launcher' screen. I tried the above suggestion and when I launched WoW again at first it went s on a new screen which says 'Updating Blizzard Update agent' and got stuck, so I closed it after 5 mins, then I started it again and now its stuck at the same 'Updating Blizzard launcher' screen at about 2/3 of the way along the progress bar. I've left it for at least 5 mins and it just seems 'stuck'. I even rebooted my computer to see if that would help. I checked and I have the latest version of Adobe Flash Player as well (I saw this in another post and checked this too). Please can you advise?

1. Lets first make sure that your Windows Secondary Logon Service is enabled.

Here's a support article that will help with that:

2. What security programs do you have installed?

3. Have you tried doing a selective startup yet?

Here's how:

Please be aware that running while in this mode can potentially disable any security programs you may have running.

Hold the Windows key on your keyboard and press the letter 'R'. In the Run field type "msconfig" and hit Enter.
In the General tab:

1. Choose Selective Startup
2. Disable (uncheck) Load startup items
3. Click OK and Reboot

To undo selective startup, just recheck Load startup items.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
OK, in answer to your questions:

1) Secondary logon was already enabled, but it was set to Manual. I changed it to Automatic

2) I am using ESET NOD32 Antivirus

3) I am trying selective startup right now. I should point out that I already decided to uninstall WoW completely because I couldn't find any other answers on the forums. I made sure tha no folders were left behind after I uninstalled. I then downloaded the WoW Installer rebooted my computer (without startup items). It is now sitting at the 'Checking for updates' screen and has been that way for 5 mins or more, no progress bar at all. What is going on? Everything was working fine for me this morning. I must have launched WoW about 5 or 6 times today throughout the day and had no problems at this....

Can you try temporarily disabling or uninstalling ESET NOD32 to see if that makes a difference?
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Yes, I tried that and it made no difference(it wasn't even running when I was in selective startup with no startup items loaded). As stated before, I have been able to run WoW without any problems today and I haven't changed anything on my computer. Now I can't even get the install program to run correctly. Is there something going on at Blizzard's end that maybe we're not aware of? It makes no sense that the launcher just 'stops working'.

This will have to wait until tomorrow now as I'm tired and I haven't got any more patience to work on this tonight. Perhaps you can help me again tomorrow, as I'm in the Eastern time zone, I guess I'll have to wait until later in the morning(hate these time zone differences).
Thanks Tratt. I looked for any other temp files, etc and couldn't find any (though I did delete all my temp files just for good measure). I think at this point I may just submit a ticket as the page you pointed to suggests. Very frustrating :(
OK, so I finally got WoW to install (or at least begin the long process!). I discovered that it was a Microsoft update that I had applied to my computer yesterday that had somehow messed with other stuff. I only figured this out because one of my streaming radio players was asking me to update it and every time I pressed 'update' it just sat there. I eventually put two and two together and did system restore back to before I did the Windows Update and after running a scan disk to be on the safe side, I got back into Windows and now the WoW installer works. So for anyone else out there that has been having recent problems, check your other program and try a system restore to when WoW was working, this is what worked for me. I just wish I hadn't uninstalled WoW now, perhaps it would have worked after the system restore....oh well.

Thanks to Dankorii and Tratt for their assistance!

You're welcome, I'm glad to see that the system restore helped. Please feel free to post again if you have any other questions.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information

Join the Conversation

Return to Forum