Dailies on Darkspear not working?

Customer Support
Specifically the August Celestials, only the "The Siege Swells" is working. The other quests I accepted but cannot be done because the items/objectives like wagon aren't spawning.
You could be raid group bugged. Type the following in exactly and then hit enter.

/script LeaveParty()

Then see if the objects appear or you are able to loot them.

Other then that make sure you are not phased from another quest(line). That can interfere with your ability to do other quests until you finish any phased ones.
Other players are experiencing this as well. I tried to /script LeaveParty() that didn't work. Tried hearthing back to the Golden Lantern and flying back, dropped quest and picked them up again but the issue still persists =/
is it the one near nizuao? if so that set of daily's bugs sometimes i do not know of a fix other then a wait and restart the server. basically have a 1 in 4 chance of encountering that set.

maybe in the near future they will fix the bug but i would work around it for the time being.

Join the Conversation

Return to Forum