Stuck on success!

Technical Support
Loaded wow...Launcher came up with 5.1 patch notes. Game updated, then was ready to play. I try to log on, says connected for a while, then success! for a looooong time. I log on daily, so there was no need for an update. I had no issues yesterday or last night.

Ive re-started computer and my modem. Same results.

Please advise.
I am having the exact same issue.
My husband and I (separate accounts, separate computers) are experiencing this same issue. We have restarted the system (network and PCs), removed WTF and Cache directories, and removed all of our add-ons. I played earlier today with no problem, but have been unable to successfully connect since about 2pm PST--Verizon FIOS, Plano, TX
Let me guess, you all use Verizon?
Me and my fiancee are also having this issue. We do have verizon.
Yes..Im a Verizon FIOS user in the Dallas area.

Update: I left it alone on Success for about 5mins. Came back and I was at my char select screen. Loading took exponentially longer, but once I got in game, all has been fine so far.
Yep, I use verizon.
Yeah, I totally want to call them and scream at them tomorrow on the phone. But thats probably just me being tired and that doesn't accomplish anything. The only people getting screwed over are Verizon users. If this goes on for another full day, I expect compensation in return. This is silly. They've had quite a bit of time to fix the problem now.

P.S I also live in Dallas. Obviously we need a forum to QQ in and set up a location to go get drinks :/
I use Verizon and I live in Denton. (Just north of Dallas). This issue seems to happen to us all at the same time. It happened a few weeks ago too. It's happening to me right now, among other issues.
I also couldnt log into my armory app on my phone. I turned off WiFi and went to AT&T LTE and logged in easily. On WiFi I kept getting the "port blocked" message.
Verizon FiOS user here in North Dallas. Been having connection issues since about 2pm CST til now (9:38pm). Either get stuck at Success screen, stuck on the loading bar screen or can play for about 30 secs then get D/C'd.

I have the 75mb down / 35mb up plan. I also have connection issues with Diablo 3 just to test it. Then played CS:GO and have like a 6 ping and plays flawlessly. About to test out Planetside 2.

System Specs:
i5-3570K
16GB RAM
GTX 670
Samsung 840 Pro 256gb SSD
My husband, myself, and another local friend of ours are all also having this issue. We're also from the Dallas area and on Verizon FiOS. :(
Dallas area also, stuck on loading screen --- Verizon FiOS.
Same location--Carrollton, to be precise--same service.

Same issue.
Verizon Fios in Coppell, Texas (north dallas). Same issue, forums load extremely slow too, i think its a battlenet related issue but who knows.
Dallas-area (grapevine, TX)
yup. i'm definitely having the same problems as y'all.
forums are loading slow for me as well.
dangit Verizon, i just want to level my Mage :(
I'm talking with Verizon customer support right now. Trying to escalate the issue with them... we'll see what they say.
throwing you guys an update,
i can now login. i ran the repair tool through the launcher. moment of truth

yup. i am playing flawlessly now. hopefully all of you guys can as well.
see you guys in azeroth!
Verizon reset my connection on their end. Problem seems fixed for me!

For now.

EDIT: Nope. T'was a lie. Was able to login fine. Logged out to test, closed WoW down, relogged; stuck on 90% loading screen.

Not solved.
Same problem in Auckland, NZ. Stuck on success.

Join the Conversation

Return to Forum