Error #2

Technical Support
I keep getting this everytime I try to log on. I know my internet connection is fine because my boyfriend whose on the same network is connected any tips?
Note I have already reset my modem my router checked for updates on windows scanned my computer for viruses cleared my cache etc
I have the same error. Have tried everything possible. Something is wrong with WoW after the patch update.
Have you ran the launcher to make sure it says Game is up to date? Typically I see this happen when some hotfixes have been released, but the launcher is being bypassed, so you may not see these updates.
Yep game is up to date, even tried deleting the update and running it again. Still error #2 when trying to logon.
Have you tried removing your Battle.net Cache to see if this helps?
Yes, still Error #2.
Can you post the contents of your connection.log file? This is located in the Logs folder of the World of Warcraft directory.
I have the same problem, even though I reset the router, shutdown thecomputer to clear everything, released, renewed, flushed the dns and deleted all the recommended folders. Internet is working with everything else but wow since the new patch
here's my contents from the connection log

3/5 16:55:12.171 Login program=WoW platform=Wn64 locale=enUS
3/5 16:55:12.171 Component WoW.Wn64.16650
3/5 16:55:12.171 Component WoW.base.16650
3/5 16:55:12.171 Component WoW.enUS.16650
3/5 16:55:12.171 Component Tool.Win.1276
3/5 16:55:12.191 GRUNT: state: LOGIN_STATE_CONNECTING result: LOGIN_OK
3/5 16:55:12.211 Connecting to 12.129.206.130:1119
3/5 16:55:12.211 GRUNT: state: LOGIN_STATE_FAILED result: LOGIN_SERVER_DOWN
3/5 16:55:12.221 GRUNT: state: LOGIN_STATE_FAILED result: LOGIN_FAILED
3/5 16:55:12.221 Client initiated Disconnect from 12.129.206.130
3/5 16:55:12.231 Client initiated Disconnect from 12.129.206.130
3/5 16:55:12.231 GRUNT: state: LOGIN_STATE_DISCONNECTED result: LOGIN_OK
3/5 16:55:12.231 Login program=WoW platform=Wn64 locale=enUS
3/5 16:55:12.251 Component WoW.Wn64.16650
3/5 16:55:12.251 Component WoW.base.16650
3/5 16:55:12.251 Component WoW.enUS.16650
3/5 16:55:12.251 Component Tool.Win.1276
3/5 18:04:41.254 Login program=WoW platform=Wn64 locale=enUS
3/5 18:04:41.254 Component WoW.Wn64.16650
3/5 18:04:41.254 Component WoW.base.16650
3/5 18:04:41.254 Component WoW.enUS.16650
3/5 18:04:41.254 Component Tool.Win.1276
3/5 18:04:41.284 GRUNT: state: LOGIN_STATE_CONNECTING result: LOGIN_OK
3/5 18:04:41.294 Connecting to 12.129.206.130:1119
3/5 18:04:41.294 GRUNT: state: LOGIN_STATE_FAILED result: LOGIN_SERVER_DOWN
3/5 18:04:41.294 GRUNT: state: LOGIN_STATE_FAILED result: LOGIN_FAILED
3/5 18:04:41.294 Client initiated Disconnect from 12.129.206.130
3/5 18:04:41.294 Client initiated Disconnect from 12.129.206.130
3/5 18:04:41.294 GRUNT: state: LOGIN_STATE_DISCONNECTED result: LOGIN_OK
3/5 18:04:41.294 Login program=WoW platform=Wn64 locale=enUS
3/5 18:04:41.294 Component WoW.Wn64.16650
3/5 18:04:41.294 Component WoW.base.16650
3/5 18:04:41.294 Component WoW.enUS.16650
3/5 18:04:41.294 Component Tool.Win.1276
Thanks for providing this. I'll see what more I found out about this error. It is a bit puzzling that the log says server down...
Question. Have you tried to startup in selective startup to see if this helps? It may be due to interference from a security program that is causing this since it is a new version of the game.
I was getting the same error, had to turn off my firewall to login
Wow this worked, wouldn't think my antivirus would have caused it, never got any pop-ups saying anything was being blocked.
Awesome.

Can you check to see if you have any pending updates for your security programs? Generally we send out information to security companies letting them know we've updated our version of our game and tools.

Also, what programs do you have installed?
No updates, I'm running norton 360
Thanks.

In the mean time, we've updated our Battle.net Error #2 article to reflect newer information about this error, and updated troubleshooting steps.

I hope this helps others who may have this issue.
i have also tried all of these and it is telling me battle.net error#2 unable to connect
Wait! What worked for you??

Join the Conversation

Return to Forum