Beasts of Fable

Bug Report
1 2 3 5 Next
I just beat Dos-Ryga in Kun-Lai Summit but I did not get credit according to my quest tracker. I'm not sure if this is just a bug of it not checking off but actually counting or it does not give credit at all.

Edit: After beating him a 2nd time the quest gave me credit.
I am having the same problem. I killed Dos-Ryga twice and the quest never gave me credit, the same thing happened with Ti'un the wanderer. I haven't tried the other beasts yet.
I was able to beat each of the 10 beasts last night getting credit on the FIRST kill. Today, I just killed Lucky Yi, Greyhoof, Skitterer Xi'a, and Ka'wi the Gorger before noticing in my quest log that I had only received credit for Lucky Yi. Quest credit is bugged. :(
I'm having the same issue but fighting 2 or 3 times won't give me the credit (Ka'wi and Nitun so far )
This issue seems to be fixed now.
Did your pet die after Dos-Ryga died? I ask because this happened once to me but it's because my pet died from the whirlpool after Dos-ryga so in the end no pet won and i didn't get credit. All other times when I defeated him with one pet remaining I got the credit.
The issue is *not* fixed. I beat the Skitterer twice without acknowledgment of defeat on the quest log, so I moved onto Gorespine. I received no credit for beating him either. This is more than a little annoying.

Update: After trying again, I can't even fight Gorespine now, with the error message "Failed to create pet battle" repeating each time I try. Logging out and in failed to correct this problem.
Just beat Greyhoof 3x's and still not receiving credit.
I'm having the same problem so far with Dos-Ryga. Killed it twice with another pet alive (No whirlpool stale mates).

I've currently ticketed a GM to see if they can give me quest credit. I'll report back once I find out...
I'm still not receiving credit for a win on kills as well. Gave up after my third kill on Greyhoof.
Beat Kafi and no credit. Pets were still alive after the fight.

I'm having this problem on the daily. The initial quest had no issues.

I guess I'll just wait to do the daily again when they fix it in 4 months.
I had no problem on wed/thurs doing them all on my main. Today I tried to do them on an alt to get him some lesser charms and it didn't give credit, hopped back on katz (who i'd picked the quest up on) and tried again and they did work.
Update: I did get a responce from a GM when I ticketed it, however, there was nothing that could be done short of abandoning the quest and starting over which in this case can be a huge pain. They are aware of the problem though.

I must also add that upon leveling an alt of mine, I came across the same problem on a quest where I had to kill a given number or mobs. After 1 or 2 kills it stopped giving me credit. Relogging corrected this issue until it stopped giving me credit after a few kills again. It was very irritating but I managed to get it done at least.
I'm having the same problem with the Beasts of Fable quest. I relogged, reloaded, completely logged off and restarted, killed the same beast multiple times, tried another one ... still they just stopped counting.
Tonight I battled and defeated 4 of the "Beasts of Fable" before i realized that i was not getting credit. I tried the Reload reset stuff and nothing worked. As tough as these guys are this really sucks. Please Blizz devote a lil' time and fix da bugs here.
Same issues as listed above - I've defeated Lucky Yi about 5 times now [It's obviously counting as wins for me, because my lower level pet is getting exp (its not much, but thats for another thread)] and not receiving credit for the victories.
No-No and Gorespine for me.

I actually dinged 5000 kills off of No-No, and had 2 pets alive at the end, but no credit.

So frustrating, considering how much of a time sink this daily is.
I had this problem today, beat Greyhoof 3 times and no credit. So I shut down the game, deleted the Cache folder, logged back in and beat him again. Worked that time.
Just beat Skitterer Xi'a three times now without getting credit for the quest.

Edit: Restarted WoW and beat him again. Gave credit.
I didn't get credit for Ka'wi or Nitun until I logged off and tried again.

Join the Conversation

Return to Forum