Quest: Setting the Trap

Bug Report
I have been out here for over an hour now and killed Echo of Kros twice now. One time in a group and one time not in a group. Neither time have I received credit for the quest or the other people that I was in a group with. Is this suppose to be working this way?
^^Same problem. summoned him myself and did not get credit for the quest. I did, however get the achievement........
Same killed him 4 times in a group and not got achievement but nada for quest
Same here also. Killed him in and out of a group. Got the achieve, even summoned it myself and it took my summoning stones. But says I haven't completed.
Same problem. Killed him with a group, got the achievement (Pay to Slay), killed the boss that summoned and didn't get credit for the quest. Put in a ticket.
It did it to me to
Same here, you have to be the one that summons it. and the Group Members help assist you. So on so forth, next person summons, then you and others help that person.
Same happened to me last night.
Well, it didn't work for us tonite. I summoned him, didn't get credit for that part. We killed him. Didn't get credit for that, either. And neither did anybody else that was there. Jeez, Blizz. That really sucks.
I have attempted this quest multiple times and even summoned the boss in a party and have not completed the quest. It consumed my 3 ritual stones and did get credit for that but no matter what I do cannot get credit for the Kros kill. I have joined a couple other parties and still not able to get the kill portion of "Setting the trap".
I was running around Isle of Thunder today, killing elites while waiting for the GM to respond to my ticket and got an LFM call to help with Setting the Trap so I volunteered, on a hunch. Before I could get to the boss, they had summoned him and that part of the quest completed! After killing him, I got the second part of the quest completed. Not sure what the deal with the quest is or how it got "fixed" but try completing the quest the next day and see if that resolves it the way it did for me.

One problem is that if you turn the group in to a raid, the quest won't complete. After comparing notes with a few others on the Isle, that was my problem.
I summoned him (with a PuG), we killed him, I got credit for the kill but didn't get credit for the summon. The stones were consumed of course so no chance of re-summoning him. Tried joining another PuG later and didn't get credit when they summoned him either.

Put in a ticket but there's an estimated 2 and half day wait :(

Edit: Got a response. In short, the response was "Please try completing it again".
So basically, since they've decided to limit the acquisition of stones, the response was "Wait a week, until everyone else has moved on to the next phase, and pray you can still find a group to do it then."

Real freaking helpful.
Luckily I found a group who didn't mind me leeching their summon and didn't mind I couldn't help them with the rest of the chain.
I summoned it, someone else tagged it, and I lost both the kill and the stones. Brilliant.
Kind of ticked off I summoned it and another group got the tag now. I am waiting for people to let me into another group for the tag which they are not doing it needs to be like the rest of the 5.2 bosses. Because NO one wants to help anyone out!!!
I summoned it, someone else tagged it, and I lost both the kill and the stones. Brilliant.

Same here. I'm not going to participate if I'm just gambling my stones.
Moral of this story is if you're gonna do it, do it in a guild group because they won't screw you over.
We had the same problem today and is shocking Blizzard actually ignores this. The quest says nothing about the kind of group party or raid, you are wasting your time trying to do something the quest is asking you to do and of course you end up with no result. Wasting your time and not being able to play the game you are paying for sounds like a legal issue. More, after so many tickets I am 100% sure someone knows about this problem but obviously they don't care.
This game used to be fun and relaxing, now you bump into issues no one is fixing more and more often. If I have to read 10 pages of forum notes and browse youtube 2 hours to finish a quest it means the person in charge is not specific and dedicated to describe the quest objectives properly and lack of interest towards customers means lack of respect for their money soon they will lose our two subscriptions but I'm sure they won't care...

Join the Conversation

Return to Forum