Problem getting Account Auth page to load.

Website Bug Report
I have the Battle Chest purchased but I am having trouble getting to the account auth page.

The webpage at has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

This is what I get when I log in and try to load the auth page, I have tried to load it on Firefox, IE, and Chrome and it gives the same "too many redirects". I do not have cookies blocked in either of the browser and haven't ever had such a problem.
Does anyone have any idea how I can get this fixed and get my account authed so I can actually enjoy the full features of the game?

03/02/2013 10:40 AMPosted by Buradi
I have tried to load it on Firefox, IE, and Chrome

Did you delete your cookies, cache, temp files, and current log-ins? In firefox just check everything let it delete. Restart your browser and try again.
The page isn't redirecting properly

It still pops up with this. And the IE and Chrome are fresh installs too so I haven't messed with cookie settings and blocked them. It has me really scratching my head.

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept
How are you getting to that page? A link? A bookmark? Typing it in?

If you are using a bookmark or a link in an email, make sure that the link says and not or

That error was fairly pervasive awhile back for people who were inadertently being routed to the wrong site.
I'm clicking the Account page when I login to the WoW site, Top right hand corner area.
This is still a problem. How is this /still/ a problem?

Join the Conversation

Return to Forum