Launcher not working

Technical Support
Whenever I press play on my launcher it closes like its about to pull up the title screen but then it just pops up again. Anyone else having a issue like this?
Yes, no idea how to fix it though and the Gms I talked to seemed to not know either.
Try disabling your anti-virus temporarily. I had to turn mine off to fix the problem, and I saw a post with some other people that had done the same thing.
It didn't work for me. =\
Well...it WAS working for me, then the updater got stuck...
And now, with my antivirus still off, it's not working again.
i tried to open world of warcraft and it kept saying updating blizzard launcher and stayed like that for an hour or so. so i uninstalled and tried reinstalling and all its doing is saying checking for updates and all its doing is keeps saying it any help!!!
I've got it to come up after I reinstalled the game, but as soon as I downloaded all my addons and went to login to configure them it messed up again. Oh well it'll get fixed eventually.
Im having the same problem >.<.. anyone have any ideas?
im trying to redownload but aint letting me just keeps saying checking for updates
nice to know I'm not the only one having this problem But where is the blue post already come on blizz we all waiting to know how to get past yet another one of your retarded programming errors
im having the same problem. I call the suport and nothing work. i tried:
Set secundary logon to automatic
Clean DNS
Erase the batle.net folder
check the internet config
shut the firewall

and a lot of !@#$.

I need help anyone have something diferent to try?
yeah it sucks im still trying to re install lol just keeps saying checking for updates @-_-@
Ok When cataclysm originally came out i had this very same problem and I'm not sure if this can still work. But does anyone remember how to open wow directly bypassing the launcher altogether. Or if this fix even still works for launcher errors
I am having the same issue and have tried all the old fixes when it happened at Cata :(
You gotta open the file location, right click of wow, not wow launcher, and run it as administrator, and it should open up the login menu. But you may get the red realm error and not be able to login
I am having this problem also
I am glad I'm not the only one having this issue. I was thinking about uninstalling WoW and then reinstalling it all together.
I tried that already and it had no effect it still opened the launcher regardless of whether i tried Wow or wowLauncher
Just tryed that, it didnt bypass it the launcher. Just came Open'd with the nice shiny bull!@#$ "Play" button.

Join the Conversation

Return to Forum