Fac/Server xfer; missing portal to Pandaria

Quests
I put in a ticket about this, but I'll ask here too.

I recently realm/faction changed and I can't see the portal from Stormwind to Pandaria. I've done the intro quest for the Alliance, but I'm unable to do consecutive quests. I believe it's because I already completed them on the Horde side and can't do them again.

Is there some way to fix this? Did I miss something?
Did you get to the quest where you meet the captain on the alliance ship above Stormwind that flies you out to the Jade Forest?
Yeah, that's the quest that I'm referring to. Talked to the chick and flew to Pandaria after turning in the quest. Made it to Pandaria, but no portal and no consecutive quests, either.
I'm actually curious about the outcome of this, as I recently switched to alliance and did the intro quest line, and I don't recall seeing a Pandaria portal either. I'll have to double check when I get home though.
Due to the way the story line advances, the Skyfire is no longer where it used to be as it has moved on. After a faction change, once you do the quest "The Mission" and arrive in Pandaria, you need to visit an NPC named "Taradormi" - http://www.wowhead.com/npc=69157 - who will take you back in time so that you can complete the opening Alliance quests in Pandaria to open the portal.
Ahh good to know, thx Maul. Not only have I never played Alliance, I also skipped over Cata and the beginning of Pandaria, plus I was working on both xpac's intro quests simultaneously. I'll have to check this out when I get home, and hopefully this works for the OP as well.
I'll go see if Taradormi has anything to offer me and I'll post my outcome, good or bad.
Okay, here's my results today. Same as yesterday.

No quests from Taradormi. I went back to retrace the original intro quest line and found that I can accept the very first quest in Stormwind again. I did that, and went aboard the Skyfire again. Went through the intro cinematic, came out of it with a "Speak to Admiral Whoever: 1/1 (Complete)" and breathed a sigh of relief.

Until there was no quest in my quest log. Again.

Went back to Stormwind. Hey, look, there's the first quest again. So I tried again and got the same result.
Well, at least you can see Taradormi, I am stuck on "The Mission" when I get aboard the ship it goes into Pandaria and then the boat disappears and I fall to my death. I was told by a GM to go and talk to Taradormi at Lion's Landing and she will cast Taradormi's Second Chance but she is not visible to me.
Sure would be nice if this was fixed.

You can talk to Taradormi to get to the correct phase, yes. But after you accept the quest "The Mission", if you log out or change zones (ie. enter Pandaria) the quest vanishes and you cannot do the follow up. All you can do is go back to the quest giver of "The Mission" and accept it again, only to have it vanish upon zone change.

This is a very annoying bug.

Join the Conversation

Return to Forum