Downloading Patch Info several Times

Technical Support
Why is it that I am having to re-download the same patch information several times (this isn't the first time I have had to do this). I have not deleted the data folder so saying that it is missing from there isn't going to work. I have downloaded the 5.2 information on release day and when I was trying to switch realms 2 minutes ago I received a "You must download the current patch information to play".
Just encountered this myself. I downloaded 5.2 day one., have been playing since tuesday no problem.

Was logging in an playing about 2 hours ago, tried to log in now and it's making me re-download. Using a Macbook Pro, not very mac savvy...

Any idea what's the issues?
I too encountered this issue just now. I am also on a Macbook Pro.
Kalgalath,

We just released a small client patch to resolve some bugs. Today's patch is very small and updates the game to version 16669. Tuesday's release was version 16650.
Ok, I understand that blizzard updates patch information and you have to download said information, but two times in one day is a bit ridiculous. When I logged on today around 2pm the download did its thing. At 1am I tried to switch realms and when the realm screen came up all realms were in red. I completely logged out of the game and re-launched the game and the downloader started up again. This is getting a bit monotonous.

Join the Conversation

Return to Forum