Cursor problems

Mac Technical Support
The most common problem i have is that the wow "gloved hand" cursor will not show up and i will be left with my black default mac cursor, whats wrong with this is that when i click and drag to move the camera the mouse disappears for about 2 seconds then appears again sitting in one spot even though i haven't released my click.
The cursor also disappears completely sometimes and it only comes back after random amounts of time, even so when it does it just reverts to the default mac cursor problem.

I have tried editing my file to add SET gxcursor "0" and all that does is makes a small laggy wow cursor appear behind my mac one. I went into system>advanced>hardware mouse and tried both options but all that happens is one option (i forgot which) makes the miniature laggy wow mouse appear again and the other does nothing.

I am on a Macbook pro Retina mid 2012 model, running OSX Mountain lion. I am also using a Razer naga Epic with the wire plugged in directly to the mouse.

I usually have a dual monitor and the problem occurs when i tab into it and back but even when i disconnect it, restart my wow and play on only one screen the problem persists from the moment the client starts.
When i play i use Windowed (fullscreen mode)

I hope that is enough information, thanks in advance for help on the matter.
Can someone please respond? i still have the problem and nothing i can find on google is helping me.
I have a similar problem in that the in game mouse cursor becomes the system cursor in windowed mode. Just started happening recently.

You might want to try this console reset with a macro to see if it fixes your issue as well:

Good luck.
I am having this problem. I tried toggling Windows modes and it's still showing the Mac cursor. very frustrating.
Restarting the I Mac worked for me.
This problem occurs for me in the same manner. I use the Windowed version because I am constantly switching between my web browser and WoW. When switching between the focus of windows this happens quite often and the cursor is lost for about 2 seconds as everyone else sees. When this happens, I have to frantically shake my mouse curser after re-focusing on WoW to get it to appear properly or minimize to the Dock and pop WoW back up again for it to run normally... This is definitely a mac issue that needs to be addressed...

I run my second Monitor (extended via HDMI) on my Macbook pro and keep my web browser on that screen while WoW is on my main laptop screen.
Had same problem here. A simple reboot, however, did the trick. Fyi, tried switching to Fullscreen mode (worked but made 2nd monitor (showing Spotify) non-functional) and Disabling Hardware Cursor in settings (also made "glove" reappear, but was dreadfully sluggish).

Join the Conversation

Return to Forum