Stormwind to Pandaria portal is missing.

Quests
This is the order things have happened so far.

1. I faction changed from Horde to Alliance
2. I signed on and got the initial Pandaria quest.
3. I completed the quest.
4. I took portal from Paw'don back to Stormwind.

The problem? The portal hasn't opened yet from Stormwind to Pandaria. Not only is it not open, it's not even there at all. How do I get back?
Once you get to Pandaria from the initial quest after faction changing, you need to speak with Taradormi and have her send you back in time slightly to get the other quests in the chain for opening the portal.

http://www.wowhead.com/npc=69157
Thanks for your help, I was able to get a mage port me in and I spoke with Taradormi. She has sent me back in time.

Progress pending.
I have completed a plethora of quests, still no portal. Open ticket with GM pending.
Same problem. I don't see any of the progression quests at all despite switching between phases a couple of times now. Last quest I was able to complete after switching (back) to alliance was getting on the air ship for the 'first time'. It crashed as I was zoning and tada, quest gone and in the same boat as you ;)
So this quest is now available for me again, going to try it - see if you can get it maybe?

http://www.wowhead.com/quest=29548
Nope same result. Every time I choose 'yes I am ready to travel' the quest disappears and I phase again
In stormwind find island with hot air balloon. The portal to paw'don village is your portal back to pandaria
is there a portal anywhere I checked the island and nothing how can I get to pandaria?
If you're trying to go to Pandaria on that character, you'll have to wait until you hit level 85. If it's a different character who is 85, you should have gotten a quest automatically when you entered Stormwind (or Orgrimmar if they're Horde) which unlocks a short quest chain that eventually takes you to Pandaria. Once that chain is complete, you should have the portal available in the small Pandarian part of the city.
you fly onto the ship and say im ready to travel then it just takes you to pandaria
what Initial quest after faction changing? quest name and npc anybody?
Make sure you accept a quest called "The Mission" cause that should make the skyship appear. From there just get on the skyship and quest away.
Had the same thing happen on my druid. He did the blimp quest, got a level over there, and when I came back to Stormwind... no portal. The big difference is no faction change, its just not there. And I can't take the blimp back.
I think this is fixed now, over by the Monk Trainer "Aysa Cloudsinger" is the Portal back to Paw' don Village, I just had this problem, and I was playing around and found the Portal back. NOTE: You must have completed the quest to get to Pandaria first!!!!!
Similar problems here, with never a faction switch.

I talk to the king after hitting 85, get a couple of quests to do, chasing a prince around, etc. Follow them all up. In the end, no access to Pandaria, no portal, no quest to get there. I get a quest sending me up to the Highlands, but that seems to result in only another long chain of quests that lead me nowhere. I have MOP. My shammy had the same problem, eventually the resort I chose was to send in a ticket and have a GM fix it.

Given 5 more alts on the alliance side, most of which are nearing level 85 or past it, I can't put up a ticket for each one, or at least I don't want to do so. I just tried it with my 85 mage, and same problem. What did I miss here?

Edit: Argh. Just found it. For those who are as frustrated as I was, I missed a quest from the npc standing in front of the castle, sending me to the Skyfire. Found it by scouring the area for any quests I had missed. Doh.
they need to make it easyier
I am currently trying to find a way back myself to continue questing. Just make a damn portal for 85 + why make it so frustrating.
For those of you that switched from Horde, visit the Heroes Board to Start the Panda quest to open the portal.
This just happened again on my hunter I faction changed over to Alliance and no way to get to Pandaria yet I did like every Pandaria quest on Horde. How am I suppose to fix this again, what is the name of the mission? I feel that this is a bug and should be fixed seeing as there is new content now and I simply wanted to go to Pandaria for possible transmogs.

Join the Conversation

Return to Forum