Interacting with NPCs not working properly.

Bug Report
1 2 3 11 Next
My first thread was in the UI/Macro section, as I thought it was a UI issue.

It was deduced that it wasn't a UI issue, so another player suggested that I post in the Tech Support forums.

Lots of other people were having the same issue, and in another thread a Blue replied:
03/11/2013 01:14 PMPosted by Omrakos
I'd recommend posting this issue in our Bug Reports forum instead of here. I'm not able to reproduce it myself nor has anyone I've mentioned it too and that's really the only way I'd be able to help in here. When reporting, be sure to mention you've eliminated addons as a possible cause already by deleting or renaming your WTF and Interface folders.

So, here I am! :D

Ever since 5.2 came out NPCs are trying to ignore me. I sometimes have to click on them 2-5 times for them to actually open their dialogue/quest windows for me.

Sometimes when I click on them nothing happens at all except for their sounds and movement (they will say hi or whatnot, and turn to face me, and move their hands/etc while talking).

Other times they do all of the above, but their window flashes open for a second and then immediately closes.

Eventually their window will open like normal and I can turn in or pick up a quest, vendor items, etc. If I'm lucky this will happen on the first click like it's supposed to, but it's much more likely now that I'll have to click on them at least 2-3 times (sometimes as many as 5) for it to work.

I'm not getting any LUA errors, and I've already tried clearing my Cache/WTF/Interface(including addons) folders, and even with the default ui I'm still having this problem.

Is anyone else experiencing this all of a sudden?

Another user tried to help me out, but it's still happening despite everything we tried.

I have tried logging in with addons disabled, with the Cache/WTF/Interface folders cleared, I've checked to make sure no one else is logged onto our wireless, my world and home ms are both fine (52-54 for both), and the patch is fully downloaded and installed (I didn't log in until it was 100% done).
I have this issue as well. I have to click multiple times to get the NPCs to interact with me. I will hear they make their verbal statement they make when you interact with them, but either I get no window at all or the window flashes for a second and then goes away.
I'm having the same issue with any NPC that has a chat window like quest givers and others that just say some stuffs.
This happened to me for the first time today after I downloaded that 5 megabyte "patch", then the emergency restart happened. It got a lot better after a console reload and 8 hours.
Same here no mods at all, I even took the liberty of a clean install last night and nothing has resolved ..
I've been having the same issue
Same issue here, however, this does seem to happen with all the NPCs. I have noticed this mainly with the farmers in Valley of the Four Winds.
Same issue here, with me and my wife PC's.
same issue
I am having the same issue.

I ruled out the possibility of Addons causing this issue by deleting my WTF/Cache/Interface folders and removing all addons. I have even attempted to play WoW on another computer with a fresh install of WoW and it still persists. Addons do seem to make it occur more frequently, but this issue's underlying cause must be in the vanilla state of the game since 5.2.

Furthermore, it can be replicated by being in a busy place like The Isle of Thunder, any major faction city, or any place with enough players about and clicking on an NPC who offers services through his dialogue window. It may not happen right away, but the window will close itself or refuse to open once in a while. With addons installed, this becomes more common (annoyingly so).
Mine does this too.
Ditto here - have to click 3 times to get a response. Doesn't matter if I am the ONLY PERSON there trying to get window to open for interraction. Happens in Pandaria as well as other places like Thunder Isle (ie, this is not a problem soley on the isle).
having the same issue, account wide.
Just posting to report the same issue here, also account wide. I have to click them sometimes 7-8 times before the window shows up.
I just had this start happening to me today. Arg.
Having the same problem

Join the Conversation

Return to Forum