The Plains of Nasam

I don't know it it is a glitch or if this one requires cheating but it seems to be impossible to finish. Killing the 100 scourge and rescuing the 3 warsong soldiers was a breeze bu then it became inpossible. I have taken 5 tanks out I can kill an other couple hundred scourge and park inside kel-thuzid to heal my tank to full and repeat it several time still does not reveal the leaders name.

I tried going out and riding around with the 3 rescued warsong soldiers.

I tried going up and down each of the 4 ramps several times.

I tried letting the tank time out so that I was standing in the center with Kel-thuzid

I tried parking close to the elevated platform between the ramps

I tried walking up the ramps after dismounting,

I even went out and tried triangulation to confirm that the platform on which Kel-thuzid stands is the structure that the quest locator number is showing.

Nothing seems to work

I exited the game and came back and tried those things again

I abondoned the quest and picked it ap again.

Nothing seems to work

Time for a bug report and and a ticket I would say
If that happens to you just mount up on your flying mount and fly over Kel'Thuzad and it will count for the discover the leader portion hope this helps! =)
Thanks Drevlad, it worked

Join the Conversation

Return to Forum