Character not found?

Customer Support
I just made an alt and tried to log on it.Each time the loading screen appears but the loading bar doesn't fill and then I get "Character not Found".I was also on another character and this happened each time I tried to go into a random dungeon group.I can enter bgs but not dungeons.I put in a ticket and the wait is averaged at 5 days.My firewall allows everything from Blizzard through and I have reloaded UI several times and turned off all add-ons.I was able to send my new alt Heirlooms but can not log into it.
I'm having the same issue with all characters on Demon Soul in both Kalimdor and Azeroth. Can still log into pandaria.

Mage teleport to Orgrimmar results in: Instance not found.
Try deleting your cache?
We saw several reports of this happening earlier, Tokurro.

Are you still getting the 'Character not found' error?
issue still present for me as well. tried deleting the game cache.

doesn't happen on any other realms just demon soul for me
This character not found seems to happen if you log out wile you are dead. Just going to throw that out there
and just dont die and dc... you would be so screwed lol.

Blizz please give us a way that we can get our toons back that say "Character no found" that does not involve us waiting days on a ticket. Thank you
Possible issue with realms based in the New York Datacenter.

Please post your information on which toon , where it is in game and on what realm to this thread here.
Mac Tech Support Cerulean Cosmic Bovine from NZ
Not on active forum posting duty from Fri 6 PM NZST to Sun 6 PM NZST (IRL Work comes first)
Thank you Mr/Miss Green
Same problem I'm on Aerie Peak character not found
Getting this issue currently now... my toons on Tichondrius...loading screen gets 90% and character not found...all 3 of my toons there.
I just got the same problem. I died in a dungeon and the game logged out, and now the game loads anda character not found.

toon name: Kalebb
Location: scarlet halls (heroic)
Realm: Quel'Thalas
i have this same problem after an arena match, dc in loading screen now i cant log on with it saying character not found

character: Silenzò
location: between dalaran arena and shrine of toon moons
realm: Jubei'Thos
Happened to me also

Character : Aendoring
Realm : Thaurissan
location : towlong steppes

and my druid lvl 85 is unable to go to pandaria , when i say tht im ready to go to pandaria to the quest npc, i get a error message saying "transfer failed : invalid instance"!!
Character : Udeke
Current Location : on the warplane outside orgrimmar
Realm : Thaurissan
Happening to me on this toon (an alt) I can log into every other one of my toons (at least the ones I need; checking the others now) but mobile armory on my phone works fine for this toon too...just can't get in game to clear mailbox.

Character : Ammone
Realm : The Venture Co.
Location : Stormwind mailbox directly in front of trade AH.

Note I have at least 1 other toon logged in EXACTLY the same spot...maybe 2 or 3...
Just to note: logging all the way out and back in took care of the problem...guess I had a lesser version of what everyone else did. (I just needed to get mail, this isn't a toon I use all that much anymore).

Hope this helps/gets resolved.
Just worked for me Ammone, I logged completely out and then back in and it went through.

Join the Conversation

Return to Forum