Isle of Thunder Scenario Bugged.

Bug Report
Im doing the solo quest for Assault on Shaol'mara and have hit a brick wall. The first time I ran it on this toon, I made it to the last boss. The boss died and I did not receive credit. I dropped and re-qued. Upon attacking the first boss (the triceratops), it won't let me attack at all. It just continues to say "I cannot attack that target". I'm now at a stale mate in the instance.
Mine is bugged too. No problem completing this on my first character, then I take my alt in, kill everything except Anki. He is in the bubble with vereesa and I can't hit him.

Tried abandoning it and doing it all over again, same thing.
I did it on my first toon and one of my alts fine about a week and a half ago. But I tried it again today on this toon to see if maybe it was a temporary issue. But the same thing happened... I got to the triceratops and it won't let me attack it. I decided to run around the zone to see if it would at least let me access any quests, but nada. I'm about to submit a ticket to see if there's anything that can be done to unblock me. Dx

Join the Conversation

Return to Forum