Frozen Orb Macro Bug

UI and Macro
Disclaimer: This is my first time on this forum so i'm not sure if this issue has been noted before. I checked briefly and didnt see anything on it.

I have been using a macro for a while, i think its fairly common and its not complex at all. It is:
/Use Malevolent Badge..etc (trinket)
/Cast Icy Veins
/Cast Frozen Orb

Everything was great and the macro worked just fine, until (and im almost positive this is when it stopped working) i looted a Frozen Orb (the ITEM) off a boss in Utgarde Pinnacle.

All the macro does now is cast the trinket and the icy veins, and not the frozen orb... Ive even tried to re write the macro several times and it wont work...

Here is what really made me think it was the Frozen Orb (item) that caused the issue.

On my third attempt to recreate the macro it showed a number on the macro button on my bar. the number 2. which was the number of Frozen Orbs i had in my bag at the time. so i got rid of them.... but this macro still wont work... my friend uses the same macro and his works just fine... PLS help.
try adding a set of parenthesis to the end as if your adding a rank to the spell such as

/cast frozen orb()

furthermore if you would like your macro to be more streamlined you could also write it as

/use 13
/use 14
/cast icy veins
/cast frozen orb()

the /use 13 just means it uses your top most trinket no matter what is in there so you could put your Malevolent Badge there and it would use it, i find this way better then using the name so that way when/if you get a better trinket you dont have to rewrite your macro. same with /use 14 thats just the bottom slot hope this helps ya

EDIT: as an after thought the reason your macro broke is because the frozen orb (item) was loaded into your cache. and the game reads the item cache file before it reads the spell cache file, so it thinks you mean the item, whether it is in your bags, bank. or in the trash can. this "error" is only fixable by clearing your cache AFTER you got rid of the orbs completely, which would be annoying because it would happen again if you even saw an orb.
This specific issue is something Blizzard needs to address. You should submit a ticket. I'm sure they've received a few already, but CS may have an answer and if not Mages need to keep complaining until they do.
Its an issue I have been bothering them since they have released Frozen Orb. The 1st thing I have done when the new patch has been release was to make macro and redo my UI but up to now they still haven't done anything about it.

Famous people like the admin of wowlazy macro and his friends is also aware of these cause we had talked about it on facebook. We failed in making a fix on it no matter how good you are in making a macro.

All we have to do now is to wait for the developers to fix the dam issue they are ignoring. How long has it been since the spell is introduced? that's how long they have ignored this.

I saw too many bugs in macro. Druid doesn't read ,null making it not go in cycle or skip to the next sequence. Priest S.Fiend locks the macro to the spell making it not able to continue sequence. Warrior macro also stuck up a lot. etc, etc, etc

Believe it or not the issue has a simple fix and that is by changing the spelling. If they can have a paladin spells which the dictionary doesn't agree on then they should do the same to a mage spell. No idea why it is being ignored.
Sometimes Blizzard pisses me off SO freakin' much. They could've fixed this at any point since MoP came out. Of course, all the geniuses had to do was name the Mage spell "Frozen Globe" or "Frozen Sphere" (assuming there aren't any items with those names), and this never would've even happened in the first place.

As it is, I decided to put my Frozen Orb spell in my burst macro last night (hadn't done it before for various reasons). Of course, I ran into this problem. I added the "()" to the #showtooltip and spell cast lines. The tooltip fix worked, but the spell still wouldn't cast. I got rid of my frozen Orb items (still had 8), then cleared my cache and restarted, etc. Spell still wouldn't cast. I experimented with shortening the macro. I changed all of the lines from "/cast" to "/use" one by one and then in combinations (even though they function the same). I removed the "/stopcasting" line and my script line that clears the UI error frame. Spell STILL wouldn't cast via macro.

Then finally, I discovered ANOTHER bug related to this problem. No matter what else you change, if you have a "/cast Mirror Image" line in your macro on a line anywhere BEFORE the cast Frozen Orb() line, then FO will not cast! FWIW, the Mirror Images do work, but something about the MI spell cast line cause FO not to work, even if you've done all of the other troubleshooting steps necessary to work around this problem. But if take out the Mirror Image line or move it below the cast FO line, then it works - if you've followed all of the other steps first of course.

So for the time being, it's working for me. But THIS NEEDS TO BE FIXED ALREADY, $@*$!&@!!!!
FO and MI are both on the GCD, you shouldn't be able to cast them at the same time or use fall-through logic to cast whichever is off cooldown.
Try using !Frozen Orb instead. The exclamation point forces it to be sent to the server.
03/10/2014 09:05 PMPosted by Fraistlin
Try using !Frozen Orb instead. The exclamation point forces it to be sent to the server.

1) This thread is almost a year old, why do you think the OP cares at this point?
2) That is not what the ! does.
3) The correct answer was already given in post #2

/cast Frozen Orb()

Forces the game to cast the spell instead of using the item.

Join the Conversation

Return to Forum