Pets and Mounts disappearing

Customer Support
I have the digital deluxe version of MoP, that gave me the Imperial Quilen Mount and the Lucky Quilen Cub battle pet. I also have two game accounts that both belong to the same battle.net account.

The problem that I am having is that my Quilen Mount and Quilen Cub disappear entirely from my Mounts and Pets inventory. In addition to that, several other pets I have, such as Lil' Tarecgosa, Soul of the Aspects, and Cinder kitten still show up in my pet inventory, but the Summon button is greyed out.

I've had this problem ongoing for a while now, and have put in a few tickets in game. Someone from Blizzard restored the missing items and reset things so that I can summon the pets again; however, a few days after doing that, the same problem is occurring again.

From the conversation I had with the GM, it sounded like this was an ongoing issue. Is there any more information about it, or an ETA on when it will be fixed?
I have the digital deluxe version of MoP, that gave me the Imperial Quilen Mount and the Lucky Quilen Cub battle pet. I also have two game accounts that both belong to the same battle.net account.

The problem that I am having is that my Quilen Mount and Quilen Cub disappear entirely from my Mounts and Pets inventory. In addition to that, several other pets I have, such as Lil' Tarecgosa, Soul of the Aspects, and Cinder kitten still show up in my pet inventory, but the Summon button is greyed out.

I've had this problem ongoing for a while now, and have put in a few tickets in game. Someone from Blizzard restored the missing items and reset things so that I can summon the pets again; however, a few days after doing that, the same problem is occurring again.

From the conversation I had with the GM, it sounded like this was an ongoing issue. Is there any more information about it, or an ETA on when it will be fixed?


I am having the exact same issue and it seems to correlate with transferring characters from one account to other. And no, I am not transferring characters that earned the pets to begin with. At first it was all the store bought pets. This weeked I transferred a toon and now Murkimus the Gladiator is gray'd out.

I have had multiple tickets and a few brief fixes, but they always revert back. I could live with the store bought pets being gone but Murkimus is my most prized pet and I am losing my patience. It is especially frustrating to have paid really money for pets I can't use.
I've been talking with Blizzard's account support for a little over a week on the same issue. All of the blizzard pet store pets have become grayed out in my list, the collector's edition pets for 2 of the collector's editions are grayed out, and various mounts have disappeared as well (pet store, collector's edition & tyrael's charger).

It seems we are in the same situation, as we also did a character transfer (from one account under the same battle.net account to another). This started the whole chain reaction of broken pets and mounts.

Initially making a level 1 character fixed the pets...but only for a couple of hours. The mounts didn't start disappearing until a couple of days later. The Tyrael's charger disappeared first, followed by the Imperial Quilen mount. A day or so later all of the purchased mounts disappeared as well.

They have confirmed that this is a bug over the phone and have an active ticket open on the bug. It was suggested that I check back later this week for an update as they have no ETA right now on a fix or additional information. I was also informed that they would get a hold of me if they had any update on this.

Hopefully they'll get this fixed soon. I'm a bit worried that other pets may start disappearing from my list soon too, like the mini diablo, etc. When you have 400+ unique pets it's sometimes hard to notice one disappear, so who knows...I may be missing more that I haven't noticed yet.
It's especially frustrating to me that all of the ones that are missing are pets and mounts I paid real money for.

I hope they fix it, like you I am worried more and more will disappear.
It's especially frustrating to me that all of the ones that are missing are pets and mounts I paid real money for.

I hope they fix it, like you I am worried more and more will disappear.

I believe this is a high priority to get fixed for those that are being effected. I totally get the frustration. I to hope they are able to fix it for you soon.

I know that "some" people have been able to get them to reappear by making a new level 1 toon. This can be a temporary fix tho.
I know that "some" people have been able to get them to reappear by making a new level 1 toon. This can be a temporary fix tho.


Yes, unfortunately it is a temporary fix, lasted about a day for me.

When I logged on this morning I saw they answered my ticket on this. The ticket said Good News, I was able to restore your pets for you! It said there was a bug but they had discovered a workaround. I logged in and about 10 pets, including Murkimus are still grayed out:( Whatever they did wasn't even temporary lol.
When I logged on this morning I saw they answered my ticket on this. The ticket said Good News, I was able to restore your pets for you! It said there was a bug but they had discovered a workaround. I logged in and about 10 pets, including Murkimus are still grayed out:( Whatever they did wasn't even temporary lol.

I would select you still need help on your ticket and explain to them that they disappeared again. I also suggest making a post on the bug forums.
Since I'm really missing my mounts... I made another character on our battlenet account, and leveled it to 50something. The mounts were mailed, I learned the mounts again, and within a couple of hours they've started to disappear again :( So far Tyrael's Charger and the Imperial Quillen have disappeared. I'm guessing the store bought mounts will follow soon.

The pets are all still grayed out too.

Could we get a blue post on this confirming that this is a bug and being worked on? I'm VERY concerned that doing some searching I've found people reporting this dating several months back... It makes me worried that this in fact will go several more months without being fixed..
Same issue here....
Could we get a blue post on this confirming that this is a bug and being worked on? I'm VERY concerned that doing some searching I've found people reporting this dating several months back... It makes me worried that this in fact will go several more months without being fixed..


Yes, it started several months ago for me, so they have known about it for a while.

I was only able to use my cinder kitten for one day if that tells you how old.

Also, they know its a bug. Whether or not they are actually working on it I don't know since they can't give an ETA.
I am having the exact same issue. It started with me noticing the Cinder Kitten was greyed out. Here's the fourth ticket I just submitted:


Re: US35290657, US36110772, US33620568

I am growing concerned that this issue has not been rectified. Can it please be escalated higher?

The cinder kitten, Lil XT, Lil KT, Soul of the Aspects, Cenarion Hatchling, Moonkin Hatchling, Pandaren Monk, Lil Ragnaros are all greyed out and inaccessible!

The last GM advised me there is something that has occurred when I transferred my Death Knight to another account.

I am willing to try anything - including the deletion of the toon, to see if this rectifies the issue (I would hope I would get some compensation - ie refunds of transfers I have performed with her, or a boost back to level 85 when I create another Death Knight).

However, I am starting to get very frustrated that items I purchased with real money - these pets (one of which was for charity) - are inaccessible to me.

Upon investigation I now realise even the MOUNTS that I purchased are gone!

Swift Windsteed, Heart of the Aspects, Winged Guardian, Celestial Steed GONE completely!

It seems that everything I have purchased from the Blizzard Store is inaccessible to me.

That's a couple of hundred bucks, guys.

Please fix this for me.


One thing I am noticing - when they are greyed out their text is still yellow, where ones you have never obtained are grey.

EG: http://imageshack.us/photo/my-images/194/wowscrnshot033013220643.jpg/
Thanks for the tip about creating a level 1 toon.

All of the missing pets and mounts are there on the level 1 character - the pets are all in the pet list, the mounts are all in her mailbox.

Not a great consolation - as the mounts can not be relearned as they require a minimum of level 20.

Logging over to my main toon shows the pets again accessible again, but still not the mounts.

I have no doubt those pets will disappear again in the next day or so.
If you need to do this again, try a fresh DK instead of anything else. They start high enough level to learn mounts.
This is an issue we are very much aware of, and originally thought resolved in the 5.2 patch.

It was resolved - to a point, but some player's are still experiencing this - and they are still working on the issue.

The make a new character does work for some - but it's not always permanent. This seems universally related to transfers, but only a tiny minority of players that have had transfers actually encounter the issue. Same thing for those that we've re-sent the pets and mounts, they don't always 'stick'.
After yesterday's success with creating a level 1 and the pets reappearing, I was happy!

Today, while logged into my account with all the pets, and while pet battling with the much loved but regularly disappearing Cinder Kitten, I decided to log onto my second account (onto a little bank alt). As soon as she logged in, the Cinder Kitten greyed out. :\

Thankfully, when I created another level 1, the Cinder Kitten returned and still at the level 3 I had gotten her up to.

It is not ideal having to repeatedly create a level 1 toon just to get my pets back... but it's better than a hole in the head.
This is an issue we are very much aware of, and originally thought resolved in the 5.2 patch.It was resolved - to a point, but some player's are still experiencing this - and they are still working on the issue.The make a new character does work for some - but it's not always permanent. This seems universally related to transfers, but only a tiny minority of players that have had transfers actually encounter the issue. Same thing for those that we've re-sent the pets and mounts, they don't always 'stick'.


Orlyia,

I sincerely appreciate your response and candor. I would rather be told, "Hey we just can't fix this for you right now but we are working on it." instead of the 4th answer I just got on my ticket saying "Good news! I fixed your pets" when they are not fixed. This is just bad customer service (and bad juju mon!).

I have been without the use of ALL of my store bought pets and mounts for months now, and this amounts to a lot of real money spent and I am growing very frustrated. I have been offered no ETA on a fix and no offers of recompense for the real money I spent on items I don't have.

Now that my most prized pet (and item in the game really) Murkimus the Gladiator is gone, I am very upset.
This is an issue we are very much aware of, and originally thought resolved in the 5.2 patch.

It was resolved - to a point, but some player's are still experiencing this - and they are still working on the issue.

The make a new character does work for some - but it's not always permanent. This seems universally related to transfers, but only a tiny minority of players that have had transfers actually encounter the issue. Same thing for those that we've re-sent the pets and mounts, they don't always 'stick'.


Appreciate your response.

But, when will this be completely resolved ?
This is an issue we are very much aware of, and originally thought resolved in the 5.2 patch.

It was resolved - to a point, but some player's are still experiencing this - and they are still working on the issue.

The make a new character does work for some - but it's not always permanent. This seems universally related to transfers, but only a tiny minority of players that have had transfers actually encounter the issue. Same thing for those that we've re-sent the pets and mounts, they don't always 'stick'.


Appreciate your response.

But, when will this be completely resolved ?


When the developers figure it out.
Just got off the phone with Blizzard to see if there were any updates. Unfortunately none at this time.

The person I spoke with suggested opening a ticket in game to see if there are any new workarounds that the GMs know about, so I have a ticket open right now.

I did express my concern that it's not even shown as a "Known issue", but he suggested I bring that up with the GM in game too.

If I do get told about a new workaround that works, I'll definitely post it here... It may be a couple days before I get a response though according to the "average wait time" thing on the ticket.

Join the Conversation

Return to Forum