Can't Battle Beegle Blastfuse?

Pet Battles
Ive completed all the rest of the Quest, he's the last tamer i need, and yet when i click on him to duel, all i get is a sentence, nothing to click on to start or anything. Is this happening to anyone else? or did i not do something right?
I got mad and exited game, few minutes later logged back in and somehow *Magically* it fixed the issue.

So for anyone else getting this problem, just exit ALLL the way out and back in :)
I'm having the same issue. Tried closing down wow and restarting it but the "magic" didn't happen :(
That's weird, I just noticed after I tried restarting WoW, my quest for the northrend tamers are gone :O
Same problem - Blastfuse was the last one I needed to complete the quest, couldn't battle him. Tried restarting the game and my Northrend Tamers quest was gone and I still couldn't battle him.
necrooooooooo. :_:
Having same ISSUE!!!- I also tried restarting WoW but quest was gone!
NOOOOOOOOO.
exactly the same happened to me. very angry now >_<
Both Beegle Blastfuse and Orkrut Dragonwaste only greet me, but offer me no option to battle them. I'm not sure what's wrong. I tried as people said and quit the game then came back in, and now the entire quest to fight the trainers in Northrend is gone from my quest log. ;_;
and now after hearthing to stormwind, the quest is back. And I just filed a ticket about it. GAH
same cannot battle that guy
Same issue for me, really frustrating. Over a year later and still no fix? Cmon Blizzard..
01/30/2016 02:57 PMPosted by Starorian
Same issue for me, really frustrating. Over a year later and still no fix? Cmon Blizzard..

There is no fix because the great majority of people do not run into the issue. Best bet is to exit WoW and exit Battle.net, then reopen and see if it is resolved. If not, open a ticket.
April 2017, still happening...

Join the Conversation

Return to Forum