Unable to Install WoW Client - SOLUTION (pg2)

Technical Support
As of right now:
- I double click on World-of-Warcraft-Setup-enUS on my desktop
- User Account Control popup, 'do you want to let the following make changes to your computer' choose yes.
- World of Warcraft Setup popup, 'Updating Blizzard Agent' 'Updating Blizzard Launcher' green bar fills up and disappears after a couple of seconds
- Blizzard Launcher.exe*32 appears in task manager in processes and then disappears
- Absolutely nothing else happens

Literally the EXACT SAME THING word for word step for step is happening to me right now...Happy i am not alone but how do we fix this?
Exactly the same thing is happening to me right now as well. I have done everything under the sun blizzard have told me to do and still nothing. It will only get up to the cata launcher then stops. The update bars show up and then disappear. -_- Been happening for the last couple days for me
Kept getting error #2. Found out what the problem was. Nothing patch related. Nothing file related. Nothing to do with i-net connection. Turns out that the account had been cancelled - the rep made a mistake after getting my money and instead of extending the sub it was accidentally cancelled instead.

Good luck for the rest of you. Hopefully you'll be online and playing soon.
After reading all these posts, I am literally afraid to uninstall my game. I am at an em passe at what I should do. I did not log into the game at all yesterday after the rolling restart. This morning, however was yet another debacle. I couldn't even successfully log into the game before it crashed. I have made a post on the subject; hoping to get a blue response. I don't want to have to contact Blizzard in order to get this squared away. As many others have been experiencing the same issues, I understand your grief. It does make one want to re-evaluate their subscription. It would be a hard choice to make as I have too much invested in this game already.
OMG guys after 2 days of not playing I made a new user account in windows with same admin privileges as my main one. Clicked wow icon on desktop and it starts up launcher like nothing was ever wrong! Hope this works for others only downside is not being able to use my main user account anymore. But i am satisfied!
Hotnology that was a great idea and worked for me as well. Just made a quick second administrative account, switched to it, tried to download WoW client on it, worked perfect. Since programs are shared between Windows accounts I switched back to my main one and lo and behold the launcher icon was on my desktop and I clicked it and now I am on my regular Windows login and WoW is downloading. Great job bud I recommend everyone who was in our boat to try this. A ridiculous situation overall that makes no sense but this should get you back on your feet for now. Much thanks, Hotnology.
This seems to be working for me as well. My computer/game updated fine but my wife's which is literally sitting beside mine, didn't... Same OS (Windows 7) same network... I still don't get it.

Like everyone has said above, I tried literally everything listed on Blizzard's technical help pages and forums and nothing worked. Two days later and about one try short of an aneurysm... this seems to be working. At least, the game is now reinstalling...
I'm not a computer expert but I like to think I'm good with computers, and whatever was happening here makes no sense to me. The solution makes no sense. The fact that not a single Blizzard tech tried to address the problem in this thread suggests they have no idea either. The second account must have enabled a lost setting or something to allow the updater to connect. One of the generic solutions in the blue posts was to re-enable secondary logons (https://sea.battle.net/support/en/article/enabling-windows-secondary-logon-service) that AVG turns off - this seemed like the obvious root of the problem because (i) I had just updated AVG and (ii) when I found the setting it was actually turned off, but this didn't solve the problem. And even then AVG was active when I made the second admin account so it didn't stop the launcher from working then. Makes no sense but at least now we have a potential solution.
Still nothing, just like the amount of support I'm recieving. I tried selective startup, I tried disabling AVG, I turned on secondary logon and did everything else I could find on all the other threads. Nothing. WoW is uninstalled on my computer, the folder was deleted, and when I download the game client from Battle.net site it downloads, I get a User Control popup that I click yes to, Blizzard Launcher Updater comes up and loads through and disappears AND THEN NOTHING HAPPENS.

This is ridiculous. I pay for this, don't I?

I know you already downloaded WoW but try downloading it again, and install the newest download. the new download is what did the trick for me.

Join the Conversation

Return to Forum