cannot transmog my pants

Customer Support
Hello. I am having a strange issue with the transmogrifcation system. I have attempted to mog my pants first with the Midrealm Leggings which is the same skin as the Symbolic legplates. When I drop the pants into the slot,the price appears for what it would cost to change them & I click apply but nothing happens. I don't even get a popup to ask if I'm sure like usual.

I thought that maybe those quest reward pants were bugged so I waited until I found the Symbolic Legplates in the AH. This time I get the popup asking if I'm sure I want to add them & I get the price. I click apply then again, nothing happens. I upgraded my pants to an epic & still the same issue. =*(

I wasn't sure whether to post this in bugs or here as I'm not even sure if the pants issue is something intentional.Thanks for your time.
I have read that the costs being displayed are not accurate, that the costs are showing the prices of the items being used for transmog, rather than the costs of transmogging the items you are wearing. In short, look at the vendor price of the items you are wearing and make sure you have enough gold on you to transmog them.
I transferred 100 extra gold to this character & your suggestion worked. It kept saying that it would only cost 6g when it actually cost almost 30. thanks so much for the help!
Glad it worked :)

Join the Conversation

Return to Forum