Cannot connect to mobile armory.

Mobile Bug Report
1 2 3 7 Next
I looked to see if others were having this issue and I don't see any posts recently on the forums. But on the app feedback people today are having issues?

I have the iPhone 5.
Having the same problem. Sometimes it works fine other times like today I can't get in.
Having the same issue, have been trying to log for almost 20 mins, keep gwetting "Unable to establish connection with servers."

I'm on Android Galaxy SII
Same problem here. ;(
Still get the same message...
I was able to login to the europe region but not the Americas. Wassup Blizzard? Hope it comes back online soon.

Thanks,
Masatro
I sent in a ticket. It's been periodic since yesterday, but as of about 3pm CST I cannot connect at all. I have a Samsung Galaxy S3, everything else is connecting fine.

Wanted to update this morning 4/15/13, I still cannot connect at 7 am CST. I am able to log into the european region (not that it does me any good but I wanted to see if it would work as it did for the previous poster). I have tried 4g and wifi as well through AT&T, both are a no go. Please help Bizz!
Same issues with myself (MyTouch), my roommate (Galaxy SII), and multiple friends across the country.

Doesn't seem to be a phone build issue, seems to be a server one.
Same issue. Samsung Galaxy I
iPhone 5 here and same issue. It's been buggy the last few days and as of this afternoon, I'm unable to log in to the app at all.
Also broke for me. iPhone 4 on verizon. Same with the random bug outs past few days or random cannot connects.
Same for me on my EVO 3D.
Just wanted to add my name to the list.

Can't login with iPhone 5 nor iPad 2.

Have tried from wifi, 3G, and 4g connections, with the two latter being through AT&T.

Hope it's being worked on - I love the app :)
Queueing up :( HTC1X, can't connect. Blizzard, I've become addicted to that app! HALP!
Same issues with my Galaxy S3 on Verizon. Never had problems before tonight. Tried reboot ing the app, no joy. Uninstalled and reinstalled, nada.

Can we get some blue thoughts in here please?
Same issue here on my Galaxy. I only started using the mobile armory a few days ago, but I've only actually been able to connect and use it about 25% of the time that I've actually tried to, it always give several errors before finally connecting and then losing connection again.
I'm having the same problem-says can't connect to server. Both on my android HTC One S phone over 4G/3G and my Samsung Galaxy Tab2 over Wi-Fi. Worked fine this morning, not so much over the last few hours.

Works again now, thank the WoW gods! Time to play in the AH!
I thought it was my phone. It's been doing it all day today i havent even been able to log on one time >:(
Same problem here, iPhone 4S, not being able to connect .
just tried on my SIII+, cant connect.

Last time I connected was yesterday, just fine then.

Join the Conversation

Return to Forum