Cannot connect to mobile armory.

Mobile Bug Report
Prev 1 2 3 4 7 Next
Same here, haven't been able to connect since yesterday evening (AST). Glad it's not just me!
Same issue here.

iPhone 4, AT&T service. Tried Wifi on + off. No deal.
Glad I'm not the only one. Doesn't work on either my iphone 4s (wifi or verizon wireless) or on my ipad mini.
Same here. I have Iphone 4, Verizon.
Same problem. I have a Google Nexus 4 (Android), doesn't connect over WiFi or Telus Mobility.
I've been having the same issue as others here. I've tried reinstalling several times but nothing seems to work. This has been an issue for the past 18 hours or so. Phone works on Android OS.
Same for about 14 hours on iPhone 4S.
I'm having the "Cannot establish connection" message every time I try to log on to the app on my Droid Razr Maxx (Verizon). Can we get a blue to weigh in on this? It's been non-working since Saturday night.
Same here

on a

Galaxy Note II
Same

Tried wifi and 4G

Samsung Galaxy Note (ATT)
Same issue since Sunday. iPhone 6 running most current update 6.1.3. AT&T network. Have attempted to connect through 4g, LTE and WiFi. I'm only having the issue when connecting to America's/oceanic. I have no issue connecting to Europe, but I live and play in the US. Missing my guildies and my auctions :(
Add me to the list. iPhone 4s and Nexus 7. I guess since I don't pay for this anymore it doesn't have to work.
Having the same issue since Sunday afternoon. HTC EVO 3D
Add me to the list.

HTC Droid DNA. (Verizon)
Same

Samsung Galaxy Note II
No connection on a Andriod OS.

T-Mobile
"Connection Error. Unable to establish connection to server."

I've received this error every time I've attempted to access the mobile armory for the last 36 hours approximately. I've attempted to access the armory on two different devices and get the same error. (Nexus One, Nexus 7).
Same here, been unable to connect since yesterday evening:(

Android OS
I have the same issue. Tried last night and it started doing that, this morning still the same thing. I tried uninstalling and reinstalling but that didn't seem to work. I have a Samsung Infuse on ATT.
yeah im having the same problem i hope its fixed soon...would like some blue thoughts on this.

Join the Conversation

Return to Forum