Cannot connect to mobile armory.

Mobile Bug Report
Prev 1 3 4 5 7 Next
I'm using the Mobile Armory version 5.2.1 for iOS. I've tried logging in so many times and all it will say is either the message about "blocking port blah blah" or "Login Failed. Unable to establish connection to server." I haven't been able to log in today or yesterday.
I have tried:
-Turning on and off my phone.
-Resetting the app.
-Turning off wifi and using 3G
-Turning wifi off, and then back on
-Re-typing my password over and over

Nothing has worked. I can't use the app until this gets fixed I guess...

Quite frustrating, Blizzard...............
Are there any blue post explaining this on any other thread?
Adding my name to the list. Cannot log in on iPhone 5.
Glad to see I'm not the ONLY one having problems...not that I'm happy ANY of us are having problems.

I've been unable to connect to the server since mid-day on Sunday the 14th. I even uninstall/reinstalled the app to see if was on my end. Still unable to connect.
Adding myself to the list. Unable to connect for a couple days now. Uninstalled and reinstalled application, tried mobile data network as well as multiple Wi-Fi locations. Galaxy S3, vzw.
Putting myself on the list.

Samsung Solstice
Droid Incredible 4G LTE

Same issue.
Having the same problem, been happening a couple days now but I was able to get in after hitting "Retry" a few times. Now it isn't letting me in at all. Tried for at least 30 minutes last night but nothing. 4 pages now and still no blue post? Where are you all?

Edit: Galaxy S3
I've been having the same problem since yesterday as well. I've tried to log on so many times that my account became locked "due to suspicious activity" lol. In any case, I understand kinks will pop up and I know the issue will be resolved soon. Thanks for listening. :)
Same issue. Cannot log into mobile app due to "Connection Error. Unable to establish connection to server". Have been trying to log in since yesterday. Tried running both 4g and Wifi. Samsung Galaxy S III.
iPhone 5 here, same problem.
Yeah, been seeing the same thing here on both my HTC 4g LTE for Sprint 4g and wifi and my iPad for Verizon 4g LTE and wifi. Maybe if I try using a dial up modem...
Putting another name to the list... It makes me saaaad... ;.;

-- HTC Rezound
Same problem here also :(
Having the same issue.

Used WiFi and 4G.

Removed App
Installed App

Still can not connect.

This is on Blizzards end.

No Blue post?
Now that its a free service, its not a priority for them to fix it.
Like Alilsassy and Nytis i can connect to Europe but no to Americas & Oceanic
WoW Server: Ragnaros
WoW Region: Americas
Character Name: Erlishausen
Guild: Bleach
Phone Service Provider: AT&T
Device name: HTC VIVID
OS Version:4.1.2
Mobile Armory / WoW Remote App version:5.2.1
Any other apps you have running simultaneously at the time of the error
Times of day you've experienced the issue: NO
Authenticator on the account? (If so, which type): Yes, Mobile version
Has anyone else tried logging into Remote Guild Chat on the same device?: Yes, same problem

Used WiFi and 4G.

Removed App
Installed App

Still can not connect.
Same here on my Samsung Note 2. Have not been able to login to the mobile armory since Saturday.
For what it's worth, I cannot log into the mobile armory on either iPhone5 or iPad1.
Can't connect either
Galaxy S3 or Nexus 7

Join the Conversation

Return to Forum