Unable to make purchases from store.

Website Bug Report
Trying to purchase a matching pair of lil' Ragnaros however the store is being completely unresponsive for me.
-My cart does not update with the items I've added to it, or acknowledge that I've even added items when I click add to cart.
-Occasionally will not let me scroll through pages in the store
-When it actually lets me click check out it more often than not doesn't switch the card information from the credit cards that are saved to the list. It also hasn't let me add a new method of payment so far.
-The continue button on the bottom of that page also does not like working.

And finally, the part that won't actually let me make the purchase that I've worked so hard to get to is the place my order button on the confirmation page. The button at both the top and bottom of the page are completely unresponsive and do nothing when I click on them. I've made my way there multiple times, clearing my card each time. I get no email confirmation that the purchase has went through, no error that my card was declined for some reason, nothing happens at all.'

I'm trying to give you money! Take my money!

Edit: I should also state that I've tried both in Firefox and Internet Explorer, and IE, as expected, was even worse of an experience.

Update: Finally able to make the purchase, and the website seems to be functioning a bit better. Not sure if maybe just updates were going on in the back end or something.
Same Thing is happening to me but it wont update :(

Join the Conversation

Return to Forum