Possible armory achievement glitch fix

Website Bug Report
Hello everyone, like many people I was having issues with my characters showing the right amount of achievements on the forums/armory. I was able to solve my problem a couple days ago, I went in-game and under Display I unchecked 'Display only Character Achievements to Others' on all of my characters, and then my achievements seemed to be working on the armory, the achievements on the forums didn't update until the next day, but yeah.

It appears to have worked for a couple other people on the forums.
what achievements were missing in particular? pet , title, mount rewards? because im trying to figure out if we have the same problem. if yes, then i hope unchecking works. props to you if doing this will fix my acchievement glitch ;)

EDIT: It worked thanks my friend!
Still seeing a lot of people posting with issues about their achievements.. bumping in the hope that this might be able to help someone.

Join the Conversation

Return to Forum