Unable to establish connection to server

Mobile Bug Report
Prev 1 2 3 6 Next
Same here, just got up and tried to log into the Armory to check the AH but I get the "Unable to establish connection to server" message.
been doing it to me all day as well
Same here, I have tried about 20 times and still nothing. Hope they get it fixed soon!
Still borked. Can log in to Europe (where i dont haveany toons lol) but not the US :(
Same here..
hope this gets fixed soon, i wanna repost my auctions...
Same here...on 3G in OZ
Same here. I can't login after my breakfast
Yep. Can't login on 3G/4G or WiFi. Asked several guild members and they are also having trouble. Its a server side issue.
So who needs to be notified to correct this???
Still not working :(
Two days of Nodda connection!
Yep! Finally decided to say something in forums to find this thread. Obv something on their side. Hope fix soon
Fix armory dang it! I wanna talk to my guildies while I'm at work!
I just got my first smartphone today (Iphone 5) and i was looking forward to using this app but it wont let me sign in either. I keep getting "Login Failed/Unable to establish connection to server." Or it it'll just tell me that its timed out. Hope this is something on blizz's side and not my phone. Been trying to get this to work all day. Reinstalled the app a couple times too and tried both 4g and wifi connections to no avail. Help us Blizz :(.
I think they took the night off!
Armory seems to be broke for me today, too.
Yeah having the same issue here a blue response would be nice.
Stopped working for me around 4pm Central Time and hasn't been up since.
just seems kinda sad how theres all these posts from 2 days ago till now and still no post from blizz addressing the issue... >.<

Join the Conversation

Return to Forum