Log-in Glitch on Battle.net Sites

Website Bug Report
Prev 1 2 3 8 Next
I am now starting to get the problem of having to enter my ID and password, like others have.
I wanted to put in a ticket via the web sites, but when I tried, it really didn't allow me to say that I had an issue with the web site - even when I tried to enter in my own phrasing of it.
Not often that I ask to have an official response on a matter, but this seems to be getting progressively worse for everyone who is having the problem.
The site seems to be logging me out at least every 5-10 minutes, and sometimes seems to want me to reenter my password every time I click a link.
So, I did the ticket thing through account management, and on the second attempt, I got this reply:

Hey there Layiaissa,

Sorry for the confusion. So when it prompts for the email and password after being idle, it is because it times out. We have security features in place so that it does that. It does remember your authenticator for 30 days on the website, but it will still ask for an email and password if you idle too long or leave the page for too long. This is normal and not a bug.

I asked if this was new, because the only time I've had to deal with this, it was a website issue. If anyone got any other responses, please post them.

Edit: Reply to the question of if it's new:

Heya Layiaissa,

Not something new at all, no. You may have just had a really lucky streak or something was not working properly then. It has been in an idle timeout system like this for a pretty long time. :( Sorry again about that confusion. Wish I could explain the reason it worked that way for ya.

This doesn't feel right.
Another person with the same problem. Beginning to suspect there are many more like us but many don't know where or if they can report it.

Is everyone with this problem using Firefox? I'm using Firefox 21 (beta), and I saw earlier in this thread someone report using Firefox 20.
Yes, this is happing to me as well. I am about tired of coming to the website cus i have to put in my password each time. Please fix! And I use Chrome.
And I just got logged out of the D3 forums again after a recent post. This did not happen before and I have not so much as closed Firefox today. Please fix this...very very irritating. The fun part is that I am still logged in on WoW. These used to be linked. Please fix this!
I will be messaging blizzard support again on this matter, let them know its getting worst and that its spreading to others now
I don't think it has anything to do with which web browser you're using. It looks like bad cookies because my forum ignores keep getting reset, which actually annoys me more than having to log in every time I visit the site.
From the responses that Layiaissa got... that just doesn't sound right. Even if it's a web site timeout feature, it shouldn't be doing it virtually every time you visit the site. Even then, clearing browser cache, cookies, etc should fix the problem then as it should allow you to re-enter your information (and authenticator info, if applicable) then have no problems again.
Unfortunately, as I stated in my first post and as I'm sure others have noticed... it doesn't seem to matter what you do with your browser (add-ons or not, clearing cache/cookies/etc or not), they still have the problem.
If anything, it's a glitch/bug that is cookie-related. Something tells me that their web site(s) keep making bad cookies that are saying "Oh, yeah, they've only got about 1 to 10 minutes left before it times out".
It used to be that you could be logged in for days at a time, and you'd have no issues what-so-ever - so long as you were visiting about once or twice a day. But closing the browser for a few minutes, coming back to check an active and hot thread full of an awesome discussion.. only to have to re-login? A bit ridiculous.
From the responses that Layiaissa got... that just doesn't sound right. Even if it's a web site timeout feature, it shouldn't be doing it virtually every time you visit the site. Even then, clearing browser cache, cookies, etc should fix the problem then as it should allow you to re-enter your information (and authenticator info, if applicable) then have no problems again.
Unfortunately, as I stated in my first post and as I'm sure others have noticed... it doesn't seem to matter what you do with your browser (add-ons or not, clearing cache/cookies/etc or not), they still have the problem.
If anything, it's a glitch/bug that is cookie-related. Something tells me that their web site(s) keep making bad cookies that are saying "Oh, yeah, they've only got about 1 to 10 minutes left before it times out".
It used to be that you could be logged in for days at a time, and you'd have no issues what-so-ever - so long as you were visiting about once or twice a day. But closing the browser for a few minutes, coming back to check an active and hot thread full of an awesome discussion.. only to have to re-login? A bit ridiculous.


hopefully they find a permanent fix for this, because as I said this happens every few months, but this is by far the worst yet
If its a timeout, why is there a "keep me logged in" option?

Same issue, google chrome all updated. Sounds like a cookie bug or something.
Yeah, I wasn't buying it either, but wanted to show you guys what I've gotten so far. I haven't closed the ticket yet, but I'm kinda playing wait and to see just how much worse it can get. -_-
I guess they are trying to tell people stop using on the forums.

I think I am going to take some time away from the wow forums since I am tired about having to keep on logging in over and over again.

I think I did it 5 times already today.

I will look back in a week to see if they fixed it.
Lost count of how many times I've had to log in over the last 24 hours or so. Normally I log in once per week, if that.
Seems to be fixed for me. I haven't been logged out since Thursday morning now.
Seems to be fixed for me. I haven't been logged out since Thursday morning now.


I am still being logged out
I have been logged out at least 3 times today so it is not fixed that I can see. I have not so much as closed a tab! Make lunch - logged out. Tend to laundry..logged out. ARGH. It is also asking for separate logins on D3 forums vs WoW forums. VERY annoying.
I have been logged out at least 3 times today so it is not fixed that I can see. I have not so much as closed a tab! Make lunch - logged out. Tend to laundry..logged out. ARGH. It is also asking for separate logins on D3 forums vs WoW forums. VERY annoying.


I decided to try and see if it was somewhat related to browser. So I decided to use IE.

So far today I have not been logged out at all.

It makes me wonder if some interaction with other browsers or maybe adblock or noscript addons is causing it.
05/03/2013 01:11 PMPosted by Ariktu
I have been logged out at least 3 times today so it is not fixed that I can see. I have not so much as closed a tab! Make lunch - logged out. Tend to laundry..logged out. ARGH. It is also asking for separate logins on D3 forums vs WoW forums. VERY annoying.


I decided to try and see if it was somewhat related to browser. So I decided to use IE.

So far today I have not been logged out at all.

It makes me wonder if some interaction with other browsers or maybe adblock or noscript addons is causing it.


That's a fair assumption, I just disabled ad block on us.battle.net and will see if it works since this only started happening after I got sick of ads and installed.

Join the Conversation

Return to Forum