Log-in Glitch on Battle.net Sites

Website Bug Report
Prev 1 2 3 4 8 Next
Using Google Chrome with no addons and have been having a version of this issue for a while now. I would be fine staying logged into the main site, but if I tried to visit the forums I would sometimes be logged out and have to log back in with my email and password again. I have the keep me logged in and remember my computer for 30 days boxes checked. I rarely use the forums so it wasn't that big a deal to me. But a few days ago it also started happening with the main site as well. Now I am being logged out after short periods of time if I have the the website up, or have to log in most of the time if I close the website and come back. Even after logging in and immediately closing the website and reopening it can log me out. A couple days ago it asked me for my authenticator at what may have been the normal interval, but after closing and returning later that day it asked me for my authenticator again. It hasn't asked since then though. Having to input my my password every time I check the site is getting very annoying at this point.
Add me to the club ...I use firefox and this is getting nuts...I keep getting logged out in less then 3 mins of my web page just sitting there in the background...this never use to happen.
I would say try IE also and see if it solves the problem on this site. For some reason it worked for me.

While I would rather use my firefox it is not worth relogging in every few minutes.

So I guess I need to use IE for Blizzard sites for some reason while I keep using Firefox for everything else.

Edit: I guess Blizzard saw my post and fixed IE working. So now I get logged out with that browser also. sigh.
I was having this issue a few weeks ago, and somehow my internet settings had been changed. I'm not sure if it was a Firefox update that did it, or something with Adblock.

I had to go into Tools>Options>Privacy, then UNcheck Always Use Private Browsing Mode. I also had to recheck Enable Cookies.

I've never had to alter those settings before, so I'm not sure why they suddenly changed on me, but after I set it back, I've had no issues staying logged into the forums.

*shrug* Could be completely unrelated to everyone else's issue, but I just thought I'd throw that out there.
I'm also having this issue.

Using Google Chrome(I believe fully updated) with AdBlock Plus. Windows 7 Home Premium 64 bit.

Started a couple weeks ago. Have the keep me logged in checked and it still logs me out and asks for email and password. Seems to happen every 10 or so minutes if I haven't changed pages or even shorter amount of time. Never happened like this before..
Why are we not getting any blue text to tell us what is going on with this stupid site?
I've just done some checking with the individual cookies stored by the battle.net site. There are two cookies required to maintain login: opt and JSESSIONID. There are two JSESSIONID cookies, but the one that actually supports the login key being maintained is the one that is directed at the /support directory in the cookie.

Delete either of these cookies and you can refresh the page without being logged out. Delete both and you become logged out. I performed this test with both a Diablo 3 page and a WoW page open at the same time. Deleting both cookies killed my login for the currently viewed page. Switching to the other page that was open and refreshing it restored the cookie's functionality (and presence), and also restored my login status to the first site's page.

That is, if I deleted both cookies while viewing the WoW page and hit Refresh, I had to re-enter my login details. I was only asked for my authenticator if my IP changed as I have the "remember computer for 30 days" selected since I'm the only one with access to my devices. If I refrained from entering the login information, but instead switched to the Diablo 3 page and hit Refresh, the cookies were restored to the still open WoW session and I could refresh the WoW page and I'd be logged in again.

The /support directory listing in the session specific cookie coupled with the date this started leads me to believe that there are some bugs being ironed out with regard to the new functionality of the in-game browser client for World of Warcraft and both cookies mentioned above are being timed out improperly.

Usually when the JSESSIONID cookie times out, you merely have to click the Log In Now banner up at the top of the page and it will log you back in as your login.key and opt cookies are still valid (they have expirations at least 15 days from the start of your last session). What appears to be happening now though, is that when the JSESSIONID (/support) cookie times out, it's causing the opt cookie to expire as well.

As I noted, if one goes, you should still be able to login. I demonstrated that above by manually deleting the JSESSIONID (/support) cookie before it timed out so it couldn't wipe out the opt cookie. But when both cookies are expired or deleted (as appears to happen when the JSESSIONID cookie times out and wipes the opt cookie out), you have to re-enter your login information.

I'm going to try one final test which is to let my current session expire (log me out upon refresh) and then switch over to my other open session (I have both WoW and D3 pages up at the moment) and see if switching to the other reactivates the two cookies like it did during my manual delete and switch tests.

As it may take some time for my session to time out, it may be a few hours before I can report back on this. Once I have the results I'll post them here and see if I can escalate this issue.
Alright, I'm not getting any session timeouts (which is odd to say the least since when I take forever to type out my mini-novel posts I often have to refresh my login), so I'll take this info and see if it can be used to help solve the issue.
I know I'm still having the problem, regardless of what cookies I delete and refresh.
Personally, I see no reason I should switch to IE or another browser when Firefox has worked just fine for me.
That aside, still waiting to see some sort of acknowledgement on a problem existing beyond just other players saying they're having the same issue.
Having the same problem.
I'm having this same issue when I close my internet browser's. I have my internet browser's set to remember me and login me automatically when I re-access this website on them, But it is not doing that.

Browsers used and Update Versions when having this issue:

  • Internet Explorer 10 --> Version: 10.0.9200.16540 --> Update Version: 10.0.4 --> (KB2817183)
  • Google Chrome --> Version: 26.0.1410.64 m
  • Still having issues, with all the same information. I was hoping to come back here and see an easy fix, but no luck. :(
    Having the same issue, it's pretty annoying considering my password is 23 characters long... I'd like to see this fixed soon

    Btw, I'm using the most recent version of Chrome
    Sorry I won't use IE to log to this site ever.....I prefer Firefox its safer then IE any day.....
    Hi all,

    We were notified of this issue recently, and are looking into it. Thank you for your patience!
    Thank you so much! I was just coming here to report the same thing.

    I have to relog even if I am just inactive for a period of time. I leave the forums up while I'm in-game sometimes and in the time it takes to clear a wing of LFR, I'll be required to relog when I get back.
    Hi all,

    We were notified of this issue recently, and are looking into it. Thank you for your patience!

    Much appreciated on some sort of response. I did come on today and found myself to still be logged in, so hopefully it's been at least partially patched. :D
    I still get routinely kicked out every 15 minutes or so, or when I switch toons, and even sometimes when I navigate from section to section like forums to patch notes. Time waster.
    It seems things are back to normal now for me.

    I had not logged back in for a day and was showing as logged out last night when I got off the website. This morning when I restarted my computer and went back to the website I was showing as logged in.

    I have also not been logged out yet this morning.

    I am knocking on virtual wood that this is fixed.
    A fix was pushed out yesterday that should fix this. Let us know if anyone is still having problems and we'll take another look.

    Join the Conversation

    Return to Forum