Item restoration service broken?

Customer Support
hi, been trying for about 2hrs now to use the item restoration tool, and keeps giving me an error, saying that the server is currently unavailable, try again later.
I have been both logged in and out of the game not knowing if either affects it and tried to access all the toons on my realm, Caelestrasz oceanic.
Anyone have same issue or know a reason?
It is working for me, have you tried clearing your browsers cache? Have you tried a different browser?
just cleared cache, and normally i use opera, but just tried IE and still same error :(
Have you tried other browsers?
Have you utilized it for said character before?

If so, you'll want to post in the Website Bug Reports forum.
I have seen others report this off and on...

Would work fine on all their characters, except for one, etc..

Really there was no fix.. but they left it a day or two, and it corrected itself... like there was some corrupt data or something, and just took time to flush out.

Join the Conversation

Return to Forum