Unable to log in to mobile Armory app

Mobile Bug Report
There are times when i try to log in to the mobile armory app it says "Login Failed"
"Unable to establish connection to server."

It started late Friday on in to Saturday it seems kind of spotty but about 70% to 80% of the time I can't log in. Then some times it works out of the blue.

Oh also even if i stay logged in it won't let me check my AH or other characters. It will give me the "Connection Error" "Unable to establish connection to server." message.

iPhone 4
iOS 6.1.3
armory version 5.2.2 (I think. I can't log in to see what it is but it should be the newest update.)
I got same issue
Same deal. It's been on, and off for the past couple weeks.
Same issues
same here. tried forwarding the port and allowed it through my firewall and still nothing.
i get a thing saying i have to allow a port and i did but it wont work still
Same here, this seems to happen every weekend when there's nobody to fix it. This app is getting worse every day. Won't be long till it's completely useless.
Every other weekend this is happening. Can you have the last guy to leave the office on Friday restart the server?
I just installed the App on my 5th gen iPod touch. Login fails to connect to the server. Very disappointed. Looks like it could be a real boon, as I love the AH! Please get this fixed ASAP!
Same here....unable to log in for the past 16 hours or so
I will repost here as I had posted under the page from the 15th, as had others. The app was working fine last night but I have been unable to connect this morning since around 8am EST. I did find my ticket from the 15th, and resubmitted it, in case Blizzard isn't aware of this issue. I am getting the "unable to establish connection to server" connection error. My internet is fine, both regular and wi-fi, as everything else is running fine. This appears to be a repeat of two weeks ago.
Ditto on my ipad. Moooooo :(
Same problem, started last night, updated the app this morning hoping that would solve the problem but no luck :( really annoying.
I am having the same issue. It was reported on April 15th and Blizzard said that restarting the server solved it.

I'm adding my comment here so they know the bug has come back.

Best regards
Common Blizz...Epic Fail!
Same issue.

Samsung Galaxy S3
Android Version 4.1.2
WoW Armory Version 5.2.2

edit: It had intermittent problem since about Friday night, then I can't connect login at all since Saturday evening.
its not just phones, my nexus 7 tablet wont run it either
This is an issue which started occurring on Saturday 4/27 and was resolved on the morning of Monday 4/29.

Join the Conversation

Return to Forum