3D view of my character doesn't show properly

Mobile Bug Report
When I view my character profile (this character) and got to 3D view, the background is fine but my character appears white. The shape is present and the only thing that shows up correctly/normally is my shoulder slot. When I have nothing equipped in that slot, then my character is white and appears to be bald. This only happens to this character and when I view my other characters, they're fine. I've tried relogging and closing it from the multitasking bar. I've also noticed that the 3D view loads faster compared to those that appear correctly. I am using an iPhone 5 if that helps.

Edit: here's a photo of my character profile

pic.twitter.com/WQiZNjzcZI
i tried reinstalling it and it got fixed :)
This was likely due to an error in the cached data on your device. Is this the first time this has happened on this iPhone?
yes it was the first time it happened. it happened when i was using 3G connection.
I am also experiencing something odd with the display.
First, usually when I change gear, it usually changes the gear shown in the character icon; this time it's stuck as my healing set instead of my dps which is shown to be equipped at the gear screen. It looks correct when viewed in the 3D and it seems to be the same on the website as well. Normally it changes, no?
Second, when looking at the character in 3D (this one) I do not have the proper tail. It's supposed to be the shaded long red panda tail and instead I have a traditional bob tail.

I tried first clearing the data cached and then reinstalling to no success.

The OS is Android and the phone is the Samsung Victory 3G LTE.
^ Thanks for the heads up! Looks like it's all pandarens.

Join the Conversation

Return to Forum