wow armory not working.

Mobile Bug Report
Keeps saying unable to establish a connection.
Same here. I gotta say, these issues have been getting on my nerves. iPhone 4, 6.1.3 (to be fair, I only just updated to this yesterday) running on 3G, and the issues I get trying to multitask at times has discouraged me from multitasking in the first place.

I can't log back, instead receiving the "unable to establish connection to the server" over and over and over again. This all started in the middle of a conversation with a guildie, who's not going to be happy at all when I get on WoW today...

I tried and managed to log into the Europe and Korea servers.
same here
Same here - seems to be a weekly occurrence.
Same issue for me. It was ... half working? That was this morning. I would have to try about 10 times but it would connect (eventually). Then I made the apparent mistake of actually updating the wow app. Now, it won't connect at all.
I just got a new smart phone and installed the Armory app and it never has connected. The message is: "Unable to establish connection to server." I have no idea where to begin to fix the problem.
We are monitoring these unexpected interruptions and working to resolve them. Typically these last for a couple hours and then cease to give the error after the short duration. However, if it persist for longer durations, let us know!
I still can't connect. Are there ports that need to be open in the firewall on my router? I get the "Connection Error Unable to establish connection to server." as soon as I pick the "Login" button. A very quick response.
I've tried multiple times and cannot connect. Same error as the other folks.

Join the Conversation

Return to Forum