Battle net error #2

Technical Support
I keep getting this error. I can't login on my account.

I uninstalled WoW and installed a brand new version and still can't login.

Also, i can login on my notebook. It's my desktop what's having this problem.

It stops on connecting. Not even the screen to type authenticator shows
Same error here. I can't login. Please fix it.
Although no response the problem is solved.
I'm having the same problem, tried all of the options available to me but nothing seems to help. Guess all I can do is play the waiting game
Can you guys do a little bit of login server testing and let us know the results :

Mac Tech Support Cerulean Cosmic Bovine from NZ
Not on actively posting duty from 4PM Fridays (NZST) to Midnight Sundays (NZST)
Or When at Work (IRL Work comes first)
If needed urgently DM me at ----->
It says I was unable to open a connection to the host, port 1119. So I would assume I would have to port forward wow in my router settings?

Edit: Well port forwarding didn't work, and I tried the 4 steps to resolve the error again and they didn't work either. Continuing the quest of waiting
Thugmcgee any luck logging in? I've been having the same problem for 2 days. Sent blizz the tracert, dxdiag, msinfo32, did a selective startup, even uninstalled AVG and Norton and still no luck. It is getting frustrating.
Giving it another go here

Edit: Nope
Same prob here, error 2 when trying to log in after patch took out cache and wtf files, used repair tool and still a no go.
Getting the same thing... what do.
after the launcher downloaded the 5.3 patch, i get: error #2; unable to connect. blah. blah blah
chk url:

i have rebooted 2 x, no go.

pls advise soon, thx.

I got the same thing, have you been able to fix it?
:( same thing here
i am still having troubles with it says battle net error #2 been trying since I downloaded patch yesterday
Can you guys do a little bit of login server testing and let us know the results :


Can help when I don't have any data. Unless you count waving a rubber chicken over your computer helping :P
I've tried Telnet, and it just says (after about a minute of waiting) "Connection to host lost." Do I have to port forward... or..?
I tried the Telnet thing. I have a Telnet server and a Telnet client on the list. Did them both one at a time according to those instructions. Nothing. Still getting Error #2. Come on, Blizz.
I'm having this issue as well, sorry to say I've never used telnet before so I don't know what it is. I followed the steps from the link for window's 7 that Bluspacecow posted. So the telnet client/sever are both checked, but how do I run that program.
Been talking to customer support. just gave them a tracert, dxdialog, and msinfo

Dang is this frustrating
Same problem.

I was able to connect just fine yesterday, has something happened since then?

Join the Conversation

Return to Forum