Battle net error #2

Technical Support
I am having the same issue. I was able to log in this morning. VERY frustrating!!
I have not been able to log on since 5/20/2013. After I installed the patch the battle net error #2 has popped up. I literally have been trying to get on all day and have been doing everything the tech supports have been suggesting. Very frustrating yes!
Same here, just wasted $15 to play this month after a hiatus. Guess I need to go find a better game, no wonder WOW is losing 1.3 million subscriptions.
I'm having the same issue... Are you other people using Cox internet?
I've tried Telnet, and it just says (after about a minute of waiting) "Connection to host lost." Do I have to port forward... or..?


Are you specifically doing it through port 1119 ?

Yeah that is bad. It means the connection to the login server is being lost.

I tried the Telnet thing. I have a Telnet server and a Telnet client on the list. Did them both one at a time according to those instructions. Nothing. Still getting Error #2. Come on, Blizz.


And you results ?

It wasn't a fix. It was a diagnostic step to see if you can connect to the login server.
So 24 hours later and no fix? This is pissing me off now,
So what is being done, its bad enough to have to pay $15 but to not be able to play is worse. Bluespacecow, your arrogance is not helping. We would like a fix for the problem that works, not clarification of a fix vs diagnostic step. FWIW, I ould not even got the Telnet thing to work.
Well I've done all I could in the past 4-5 days and so has customer support

Hope you guys have better luck than me
LOL oh god how embarrassing ... so I disabled windows firewall...and I was able to log back in...so if anyone is having the same issue as me...that would be a good place to start from...
Im having the same problem for 2 weeks at this point I am very frustrated. have took in in the shop payed 148$ for a guy to tell me my computer is fine I need help please!

Join the Conversation

Return to Forum