Keyboard not responding correctly (fixed)

Mac Technical Support
Prev 1 2 3 11 Next
Same issue here. I noticed it today after I patched when I was just playing on my MacBook (without the keyboard), thought if I plugged my keyboard in I might have better luck, but still the same problem.

Logitech keyboard,
Razr Naga mouse.
I have the same thing happening. MS keyboard, mac mini i7, logitech mouse. It's like the modifiers are toggling on and not off on key release.
Guys if you have an Apple keyboard (not inherently the culprit) but non-Apple mouse try this:

Remove all of your mouse button customization and set to default or inactive. Right/left click is okay and Mouse4-6 etc. if it's default only.

Something similar happened with my old Razer. My new Logitech G500 was once customizable with WoW but now I have it on default settings. Something about the patch and drivers.


It helps a lot but not solved, even control left clicking will have "control" linger behind. Shift/control/alt using any mouse buttons will definitely cause it, even if you have default settings (which still helps). This is also why (for me at least) the problem is so obvious when gemming or using dressing room. I've also replicated it using only shift+keyboard after these adjustments.

After doing a few bgs after these adjustments the game is still totally unplayable. Taking a WoW break until it's fixed. These issues were all in the PTR bug report forums for weeks. Starting a patch with non-functional keyboard, freckle-sized cursor, messed up resolution, no new pvp vendors -- it's terrible.
Same issue happening here. I'm using a Razer Naga with the RazerNaga addon and also a macro with the [mod:shift] option. When doing arenas it was frequently sicking after using a shift+button combo.

I even tried another keyboard just to make sure that wasn't it.
Same issue mac, razer naga, and standard mac keyboard. It's making arena imposable.
Operating System: OS X 10.8.3
Keyboard: Razer Blackwidow Ultimate
Mouse: Logitech G600

I am experiencing the issue described in this thread.
I use an external keyboard and naga mouse and I'm having the same problem.
Same issue here, also with the Naga on an iMac. The game seems to think that I have Sticky Keys selected, in essence. I've checked a dozen times--I do not.
Throwing my name in the mix. Immediately after patching, my Shift/Alt/Ctrl keys stick only when using it with the Logitech G600 connected to my MacBook Pro (running 10.8.3). The laptop keyboard works fine with the mod keys.

EDIT-----
I forgot to add this: my shift/control/alt keys are not bound to the mouse. The buttons are just configured as 1, 2, 3,... The macros hold all the mods and those are bound to 1, 2, 3, ....
I am having the same problem using a standard Apple Keyboard and a Microsoft Mouse (Intellimouse Explorer 3.0) connected to a MacPro. WoW Mac Client (64-bit). Patch 5.3. Mac OS X 10.7.5.
I am not quite sure this how HELPFULL would be, but i ''discover'' a fix for this bug

i enabled the razer naga add on, and the same thing it kept STUCKED, so i decided to look for a solution, i found that when you bound LEFT SHIFT PLUS RIGHT SHIFT it works perfectly :D, so i was very happy but the control key didn't work bcuz it just have 1 button so, i decided to use command key as control key in wow mac options, and i bound my mouse button to RIGHT COMMAND PLUS LEFT COMMAND and voulah bug fixed

PLEASE FIX THIS BLIZZ :D, and sorry for my bad english hope blizz support read my message :)
I have same issue but found temporary fix for it.
Before patch in order to get shift clicks to work with onscreen keyboard i used command in terminal.
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES
After 5.3 i found it made modifier keys to stuck. By using command in terminal
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool NO
Fix the sticky modifier keys .
But without setting it to'YES' i can't do any shift clicks like link items or even open gem menu with on screen keyboard [.
By using command in terminal
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool NO
Fix the sticky modifier keys.


I found this fix to work for me. It's unfortunate for the onscreen keyboard if you need to use it. But Luckly I can arena again!
By using command in terminal
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool NO
Fix the sticky modifier keys.


I found this fix to work for me. It's unfortunate for the onscreen keyboard if you need to use it. But Luckly I can arena again!


I typed this into my terminal and it didn't do anything for me.

My mouse is mapped for shift/alt/ctrl, and while in wow it's assigned mouse button 1/2/3

I'd really like to play 5.3 already...how long on a fix?
05/22/2013 12:27 PMPosted by Vatim
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool NO

Enabling the expose fix does work. However, I am treating it as a temporary workaround because it prevents keyboard modifier keys from being used in combination with mouse buttons and keys (which is probably why all of the people in this thread have disabled it).

I am happy I can raid again. Last night I was holding my guild back and receiving taunts about switching to a PC because someone at Blizzard is incompetent and should not be working there.
This type of thing happens almost every big patch for mac users.
Ditto, same here. If I play in Windowed mode, and alt-tab away, then click back to focus on the game, the key behavior is corrected, but only temporarily.
Hoping for a fix soon. Haven't been able to play since 5.3 and getting a bit frustrated.
It makes the game unplayable currently. Far too aggravating to play.

Join the Conversation

Return to Forum