Keyboard not responding correctly (fixed)

Mac Technical Support
Prev 1 8 9 10 11 Next
Still not working for me.

My set up for years has been Shift/Alt/Ctrl on my Rat7 Mouse, and I use a Nostromo (now Orbweaver) and they were working flawlessly until 5.3.

Macro example:

/cast [nomod] Hex
/cast [mod:shift, @arena1] Hex
/cast [mod:alt, @arena2] Hex
/cast [mod:ctrl, @arena3] Hex

I can only Hex [nomod] cuz when I hold the shift/alt/ctrl button down on the mouse the icons just flutter. They don't even get "stuck" like everyone is talking about, they just flutter then always execute the [nomod] action.

This bug makes arena unplayable, so I've missed out on points since 5.3 hitting. Do you have any idea how many binds are required to play 3s compared to how many buttons are actually available on a gaming pad, or physically practical on a regular keyboard? Not to mention I'd have to relearn how to play wow cuz I've been on this set up for years.
I believe this problem has everything to do with the fact that an external mouse is involved. Nothing to do with the keyboard.
honestly i am am giving up if this was a PC issue it would of never went live. this has demonstrated that blizzard entertainment doesn't give two rear ends about there mac compatible clients for the game. we will all ways have sub par service. seriously thinking about jumping to the unsubscribing bandwagon.
they still don't get it that the issue wasn't just with macros but using an external keypad in junction with control/alt/shift.

example i have three different binds
bind1: numpad 1
bind 2: shift numpad 1
bind 3: alt numpad 1

if i was to press bind 2 i would not be able to use bind 1 or bind 3 because the shift key would stick and to use another bind i would have to tap shift to toggle the sticking effect.
I just got off the phone with Blizzard Mac support. Let me give you the "update." The Blizz rep did not even know the issue was effecting WoW users and thought it was a Starcraft isolated issue. When informed that the issue was effecting external keyboards as well as the mouse in conjunction with modifier keys, the rep stated that it would be a development issue and he is uncertain about the amount of players it is effecting or it's priority on their list. Furthermore, when I informed this rep that this issue has been persisting for over 3 weeks and that is a month of unplayable gameplay I have paid for, I could not receive a month of credited game play but be could refund that month payment at the cost of my sub cancelation. This issue has been persisting for far too long and while "updates" are being posted here, the tech reps do not even know what games are being effected or the priority level of the issue for a hot fix. I'm beyond frustrated more so because I'm afraid I won't be able to enjoy my elemental shaman in pvp while we are viable. We haven't been this good since Wrath. Yet for me to succeed in p pvp I am expected to revert to clicking because my modifiers aren't working. If this were a PC issue the patch would not have gone live until this issue was resolved. Remember, Blizz was aware of this issue before the patch went live.

Can I get a blue response to the debacle that was my tech support call? This is getting out of hand.
It'd be nice to hear from a mod since the issue still isn't resolved even after the "hotfix".
Still broken for me. Please please please fix this - its made raiding so painful, especially on progression boss fights.

I must confess I do not understand the distinction made with "external" keyboard and "external" mouse. For one thing, aren't all mouses (or mice) "external" on macs ?

I understand "internal keyboards" on laptops, but mac laptops' internal input devices are touchpads, not mouse.

I am playing on a desktop mac pro + monitor with a regular keyboard and a WOW mouse (usb cable). In my case there is no such thing as an "internal" keyboard or mouse.
This is ridiculous, it's been 3 weeks and no fix, meanwhile my characters are pretty much unplayable in this current state.
"Fixed an issue where binding a modifier key to a mouse button could cause the modifier key to become stuck."

This fix, as others have said, doesn't begin to address the issue. As several folks have said, they don't even have modifiers bound to the mouse. Several have also confirmed that this happens even when there is no external mouse, though less frequently. I've had this happen with a two button mouse where the buttons were left as defined (left-click=target and right-click=interact).

It's feeling like some kind of keyboard event when an action fires. I'm having instances where the shift/alt/ctrl key doesn't even register at times. I've pulled the external mouse, played with the trackpad, and removed macros, just binding spells to the action bar.

The bug at the very least should be updated to reflect the issue. The entire forum is willing to offer information and help to resolve this.

I just restarted the game and there was a new update. It "appears" that it's fixed, at least for me. I'm testing on all my characters, but I finally have hope!
I just logged on and downloaded a small patch as well. It does appear to be fixed. Thanks so much.
Set terminal to this, and it worked again.
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES
Fixed.. thanks Blizz. =)
Set terminal to this, and it worked again.
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

This is correct. You will need to get this terminal line in to get modifiers working on secondary keyboards and multi-button mice again.
I didn't adjust anything, but the problem seems to be fixed. Whatever voodoo, hoodoo, or gnomish sacrifices you performed, Thank You!
Logged in today (6/12), got a small patch, and it does appear to be fixed for me! Thanks guys!

FYI, I have a mid-2010 iMac, Logitech G19 keyboard, Razer Naga mouse.
Cool :)
Fixed! Thanks.
Hooray it works! It was a rough ride for all, but I seriously do appreciate all of the hard work yall put in to fixing this issue. The game is playable and enjoyable again!

Now I am not sure if this is same problem but falls under same type of thing, holding shift etc my keyboard keys will stop sometimes.

For example: holding W to run forward then A ( is bound to strafe left for me ) while holding shift then a mouse button the W or A button will just stop. I have to take my finger off of it and push it again to get it to start working again. Now I have never once had this problem before 5.3. I use g510-g510s for 2 years and for about 1 year respectively. Imagine being a melee class in arena and that happens...... It is not good at all because when you are chasing some one around an arena and the W key stops for a sec and you have to take finger off and put back on again that is the difference between a win and loose.

This only happens when I use modifiers. Same set Up that I have had for years and ran the game just fine. Any ideas?
what do you mean set terminal to? like open mac terminal? idk what file to go to
06/16/2013 11:14 PMPosted by Måniac
what do you mean set terminal to? like open mac terminal? idk what file to go to

Navigate to hard disk icon/Applications/Utilities/ and then open application called "Terminal"

once this is open, copy and paste this line into it and hit enter (make sure wow is NOT open when you do this)
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES
after doing so, quit terminal like you would any other application.
Then just open up wow and see if it has made a difference for you

Join the Conversation

Return to Forum