Stuck at Initializing...tried EVERYTHING

Technical Support
I diabled security, I enabled secondary login, I unchecked all lan settings, i used a tifil file before and after, I had internet explorer open in the background, I deleted folder numeroust times (it kept reappearing) I usually am stuck at initializing, sometimes go to Initializing being stuck but has the "setup...playable optimal" parts stuck at 0.0% nonstop. and Yes I right click, run as administrator every single time.
I have spent HOURS going through the forums doing everything any person with blizzard says or a random other player says, and to no avail. I even have REINSTALLED after uninstalling the program and after a few hours it downloaded "100%" and I click play, STUCK AT initializing AGAIN. I close out, yes close out of the agent on windows task as well, and open, now i am once again at initailiazing, 0.0% downloaded for this new patch.

Blizzard, you are making me pay $15 a month to play this game and I am not getting my moneys worth, if not, I want to be refunded for the number of days this month I am unable to play. I may have to CANCEL being a member of the game if I cant ever play, its rediculus, I was having so much fun, and now its ruined.

PLEASE do something other then offer up the advice you say to every single person and when it doesnt work, you decide to not respond. PLEASE.

Very Disgruntled WoW player.
A thought when you redownload wow did you delete the old prefetch files? This can pretty much give your new down load the finger so to speak. Did you go into your registry (start > run > type in: regedit, click ok) and delete any wow files? You have to delete everything when re-downloading the game to get it to work. Try taking out wow again and deleting those files and then putting the game back in again. Also never hurts to run Ccleaner. Good luck!
(use the find feature when in your registry and type in wow first, after deleting those files, type in blizzard and delete those too. I might have to go this route again my self as i'm stuck re-downloading the newest patch yet again. X.X Oh ya reboot when your done or you'll have to do this all over again.
Oh right some people don't go in here XD *cough* um you'll need to look in: HKEY_CURRENT_USER > SOFTWARE > BLIZZARD ENTERTAINMENT delete the whole file. POOF! Now check the two below current user and delete any other bliz files you see.
Hey letting things be for a few days worked! My game is finally up to date and has stopped downloading the patch. Just keep opening up the lauher and letting it try to download it.

Join the Conversation

Return to Forum