Loading screen gets stuck at ~90%

Technical Support
After character select screen, I get stuck around 90% on the loading screen. Happens on all my characters. I have to force quit WoW. 1/10 times it will finish loading, but then I can't use any abilities, see any NPCs, etc. Still can't logout, have to force quit. World latency is crazy high (8000+).

Tried the repair tool in the launcher, didn't fix anything.
Same here. I've tried all the usual fixed--deleting Cache and WTF folders, repair tool, rebooting, etc.--and nothing's worked.
Me too. I can log into D3 and Sc2 fine. WoW, I can not "(
I have the same exact problem. I was about to call my ISP, but then I saw this thread. I then tried other servers and had no problem logging on and perfect connections in-game (<75ms home and world). Since everything else on the internet works, I'll assume that this is something Blizzard or Blizzard ISP related and expect that it will be acknowledged/remedied quickly.
Same issue on Alleria but I can log into Lightbringer with no problems.. dunno whats up.. deleted my wtf and wtb folders.. no changes on Alleria
Same here, or sometimes it lets me in but latency is listed as 10000+... and I cannot interact with anything in game... very frustrating... D# is fine... WOW.. not so much... FIX IT!!!!
Same here, or sometimes it lets me in but latency is listed as 10000+... and I cannot interact with anything in game... very frustrating... D# is fine... WOW.. not so much... FIX IT!!!!

I can log in to WrA perfectly with no latency issues. I log into tanaris and it's 6-8k ms My jimmies are almost to the point of rustled!
Same, been this way since around 7:30 ET tonight. I logged on right after servers came up about 3:15 and it worked fine then.
Interesting thing I just noticed: I tried creating a character on Ysera, which is on the same Battlegroup as my main server, and I was still getting the bad latency. However, when I created a character on Muradin, on another Battlegroup, the latency problem was gone.

For anyone else logging on to other servers without issue, are they on the same Battlegroup as your usual server, or different ones?
Tracert for Gilneas:

Tracing route to over a maximum of 30 hops

1 <1 ms <1 ms <1 ms CISCO07989 []
2 <1 ms <1 ms <1 ms speedstream.domain.invalid []
3 23 ms 23 ms 23 ms REDACTED
4 25 ms 25 ms 35 ms REDACTED
5 47 ms 48 ms 48 ms REDACTED
6 46 ms 47 ms 47 ms
7 76 ms 80 ms 78 ms cr1.dlstx.ip.att.net []
8 162 ms 103 ms 78 ms cr2.kc9mo.ip.att.net []
9 77 ms 75 ms 75 ms cr2.sl9mo.ip.att.net []
10 76 ms 75 ms 78 ms cr2.cgcil.ip.att.net []
11 74 ms 72 ms 73 ms gar3.cgcil.ip.att.net []
12 75 ms 75 ms 75 ms
13 201 ms 127 ms 76 ms
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

So, yeah... it's getting out of my house and out of my ISP just fine.
mine says 0 broad band 0 ms loggin on kt dealted all addons everythang
Here is a link to battle groups and it looks like it may just be our battlegroup.. I'm on Alleria what about the rest of you?
I'm in a different battlegroup.
yep so the only thing we all have in common seems to be we are all on EST time servers?
I am on a CST server.
I'm having the same problem also.
I'm on Khadgar on New York datacenter, problems. I logged onto a char on Cenarius on Phoenix datacenter and it worked fine, then tried one on Laughing Skull on Chicago datacenter and problems (same as you Sparky on Alleria). Seems to be eastern datacenters New York and
Thanks for the update.. I don't foresee much getting fixed tonight.. guess I'll check back in the AM.

Good Luck all

Join the Conversation

Return to Forum