alt/shift/ctrl not working right on mac

Mac Technical Support
I have been experiencing a problem that whenever I use a keybinding that uses a shift/alt/ctrl modifier, the game thinks that I am still holding down the modifier even after using the spell. I have had this problem on the PTR and on live.

For example:
I use my keybinding for Holy Prism (alt + w)
I try to strafe left (q) afterwards but instead of strafing it uses Freedom (alt + q) because the game still thinks I'm still holding down alt.

The only way to stop it from thinking that I'm holding down alt is to click alt again.

I have mostly had this problem when trying to bind ctrl to a button on my Razer Naga, but it also happens a lot with the modifiers on my external keyboard.

This makes the game pretty much unplayable in PvP for someone that uses a lot of shift/ctrl/alt bindings and if it doesn't get fixed soon I will have to discontinue my subscription.

Edit: Just saw the sticky that said it is under investigation, good to see that blizz is trying to fix this already.
I can confirm this as well. Having the exact same problem as you. For some odd reason.. this only happens on my mage. My druid is working fine.

I use a Logitech Anywhere Mouse. Glad to know that I'm not the only one experiencing this.
Almost the same problem. I just bought a razor naga and macro'd in the keys to control+shift modifier. Everything works great for a while then at some point WoW thinks I am holding down control so all of my buttons that dont have a modifier will not work. I also use a nostromo key pad. Any fix for this would be appreciated.
Are you guys using the razer addon?
I am using the Razor Synapse 2.0 to configure my mouse/key pad. I have done some more testing and it only happens after I use my mouse button that has a modifier. Also it effects my nostromo not my key board. I am not sure if it is because after I use my mouse the next button I hit is on my nostromo. I have to reboot to get everything to work again. I will try using just the keyboard after I use my mouse and see what happens.
Update: Still same issue, it only affects my nostromo, my keyboard does not see the modifier. I found this script that worked for some people "defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES" but it did not work for me. The other thing I noticed is it usually happens when I use Force of Nature, this is off the GCD so I dont know if that would make a difference, but could not recreate the issue when I only used cyclone. I also tried removing all my modifiers off of my naga and have the buttons use numpad 1-12, and bound the keys to my action bar.... even though synapse says num 1, num 2...ect and my action bar key binds say the same thing. When I push the mouse button it only does 1,2,3,... ect.
I lied...... it does not matter if I use my nostromo or keyboard.... same thing, after I use my mouse button with the modifier it thinks the modifier is being held down. One more thing I noticed is when I shut down wow and go to terminal and run the script from above I can use my nostromo/keypad again, but as soon as I use my mouse.... it comes right back. Before I would have to restart my computer to do that.
I'm having an issue with my Razer Naga, I'm unable to bind and modifier like shift+1 or alt+1. I recently upgrade my OS to 10.9 and updated the Razer software to 2.0... I'm not using the Razer add-ons. Using the Razer add-on allows me to set my keybindings...but I'd prefer to use the WoW interface.
I'm having exact same issue. Waiting for a fix.
The problem I am having, using the Razer Naga, original, is that the mouse apparently stops recognizing the modifiers, so the modifiers still work on the keyboard, just not on the Razer mouse.
The problem I am having, using the Razer Naga, original, is that the mouse apparently stops recognizing the modifiers, so the modifiers still work on the keyboard, just not on the Razer mouse.
I'm having exact same issue. Waiting for a fix.

Has a fix for this issue been found or created? I am having htis exact problem just updated to OSX 10.9.2 and have Razer Synapse 2.0.
I am also using the razer add on . UNfortunately key binding function also doesnt allow for the use of Shift/cntrl or alt to differentiate from the standard 1-12
any fix yet?
bump! I just made a forum for this a few minutes ago :
I listed what is happening to me there. Did this just start today? I just returned from a 9 month siesta and my key binds don't work anymore. I tried reseting my cache, wtf folder and interface folder. I updated my synapse for razor. All this and nothing.

My problem started after I restarted my computer after all the downloads were done. Before my computer's restart the shift key binds were working and I was comparatively doing well in raid finder. ^_^ ( Even though I barely remembered the fights and how to heal.) But my shift key binds were working during those fights *sad face* please fix, I enjoyed healing. (sorry for long windedness)
For I have a mac and I use this MACRO for my Fury Warrior. In the proving grounds (That I have noticed) didnt notice it anywhere else but I will check soon, the macro stops working completely.

/cast [mod:shift,@target] Execute
/cast [mod:ctrl,@target] wild strik
/castsequence [nomod,@target] reset=10 bloodthirst, bloodthirst, raging blow, bloodthirst, bloodthirst, wild strike
/script UIErrorsFrame:Clear()

I know it no longer works because the actions in the macro are in an action bar for my analysis and they are not being called.

Join the Conversation

Return to Forum