Game will not launch..... or play properly...

Technical Support
Hello looking for some help here... game was fine until I patched it this evening.

Opened launcher, game patched itself and loaded up.

When playing game, game was running slow, sluggish not loading parts of the map before I flew to it. An example of this was I was getting attacked by a mob, but saw nothing but the terrain on the screen. Loading screens also took forever and a day to finish loading.

Restarted Wow, now the launcher won't even "launch" the game. I have restarted my computer, alt crt del the processes relating to WoW.

I've had different results each time some examples of what I've encountered are...

1) Launcher says Game is up to date, click Play, Launcher then says "Launching..." stays like this till I restart computer or kill all processes.

2) Launcher says Game is up to date, click Play, Launcher closes but no game starts.

3) Launcher says game is up to date, click play, launcher then says "launching..." stays like that for an excessive amount of time(5+ mins) closes itself to boot the game im assuming but no game starts up.

Run the game without going through the launcher, and things are still slow to load, ie items not showing in bags, only the number is showing (ie 14 sha crystals I can only see the 14)

In windows task manager it shows up as not responding, but will then respond after an excessive wait. While this is happening the rest of the computer is fine to use, Skype, ventrillo, IE, you name a program and its running fine and dandy, just WoW isn't working.

Have removed all add ons ect ect tried all the usual stuff can't get wow to work how it was pre patch oO, have tried running in administrator mode deleted the blizzard entertainment folder, basically tried any fix that sounds like my issue.
This is happening to me right now. I was just raiding, decided to relog, and now I can't get back in.
Glad it is happening to other people , maybe a blue will take note .....
lol yeah right.. 7 threads with numerous ppl being stuck in a dc loop and some have been waiting on blizz for longer than me (currently 4 or so hours for me). might wanna take a nap while you wait, i think blizz employees sleep in the middle of the night. xD
Another update for blizzard.... run the repair tool at 15.8% this happens...

"An unknown error (2212) has occurred when attempting to download data."

Now, I'm not sure if this is what is causing the game to stuff itself, but I've turned firewalls off, anti virus software off, tried with them on, but continually get the same issue.

Have run the game in admin mode and not in admin mode.

Please fix ASAP, cause atm this is terrible service, pushing patches that make so much issues.

Join the Conversation

Return to Forum