Just Around the Corner, quest seems to be bug

Bug Report
I'm trying to do the quest "Just Around the Corner" at K3 in Stormpeaks. Appearently it appears to be bugged. I get to where the toolbox should be and see something that looks like a toolbox but can't pick it up. Nothing else around that "sparkles" and the toolbox isn't.
Same thing for me as well.
I am having the same problem. Abandoned the quest twice and re-accepted, but still didn't work.
Couldn't pick them up last night, still can't pick them up now.
Same result for me... no glowing chest, and even talked to goblin. Also dropped quest and picked it up again and still no change.
I can't complete the quest either. Spoke to others trying to do it today as well and they were not able to do the quest either.
Still bugged.
This is happening on many quests in many zones. Yesterday I had it happen on
Truce? in grizzly hills. Unclickable knife
and also in SHattered halls you could not click the braziers to get required quest items

Seems to be a problem with clickable quest items and is happening in pretty much every area
http://us.battle.net/wow/en/forum/topic/8874077792

for more on this and what has been tried to fix it (and failed)
Ditto for me too. Tried many times, and abandoned/retried. Nothing :-(
I have the same problem and also with "truce" in grizzly hills (same as Sabyrr)
Working now !!
Not working anymore
Yes, it's broken again as of yesterday. Maybe it has to do with 6.0.3? Either way tool box is unclickable.
Still bugged for me too. Submitted bug report.
Appears to be fixed now. :)

Join the Conversation

Return to Forum