Mac beta profile showing incorrect vid card

Mac Technical Support
So I decided to switch my beta profile settings the other day over to my MacBook Pro, because I find myself playing Blizzard games on it more often than on my PC. But I ran into a small problem: when I run the SystemCheck, it's finding my Intel HD Graphics 4000 384 MB and not my NVIDIA GeForce GT 650M 512 MB.

I've attempted to delete all beta settings and re-upload them, but it's still showing the same thing. I've even attempted to make sure that I was running WoW at the time so that it would pull the NVIDIA card, but still to no avail.

Any ideas? Any way to get that SystemCheck to pull the correct graphics card?
I've asked this very same question. I don't even have an Intel HD Graphic 4000 chip (or know what it is or how the profiler could even detect it when I have a NVIDIA GeForce GTX 680MX 2048 MB). I'm guessing Blizz never updated the profiler to be able to detect the correct graphic card or something. Dunno. Would be terrific if there was a fix for this.
Similar issue but on my Mac mini (2011) with AMD Radeon HD 6630M 256MBs. It tells me I have Intel HD Graphics 3000.

For those of you with MacBook Pro's, I know your Mac contains both an integrated and discrete graphics card. It switches between them to save battery life and energy costs. It seems that the Blizzard app is not taking this into account. It is possible that my Mac mini has something similar. Correct me if I'm wrong, but I believe a lot of chips are being made with integrated graphics these days, whether you use them or not.

Also, this won't help me, but if you are on a MacBook Pro there is a setting in System Preferences > Energy Saver to turn off the integrated graphics option. Possibly try running the test with this option?
Wow thanks Moogle, you're so much help!
@ Mangroas: Technically your Intel i5 or i7 (Not sure which of the systems you have) has a built in Intel HD Graphics chip, i.e. the processor has a GPU attached to it. This is in addition to the discrete GPU you have.

I'm having the same problem though, I have essentially the 2013 version of your Mac, with the GeForce GTX 775M and it only detects my processor graphics.

Unlike laptops unfortunately there is no option to force the dGPU

Join the Conversation

Return to Forum